Affiche les résultats de 1 à 4 sur 4

Sujet : Application lente au démarrage

  1. #1
    Nouveau caméléon
    Inscrit
    janvier 2018
    Distribution
    opensuse leap 15.0
    Environnement
    KDE
    Messages
    118

    Application lente au démarrage

    Bonsoir,

    Est ce qu'une application installée manuellement démarre moins rapidement qu'une application installée avec la bibli de logiciel ?

    J'ai installé manuellement Freeplane de cette manière :
    - Télécharger Freeplane
    - Ouvrir un terminal et passer en Root
    - Déplacer le zip dans le répertoire /opt => mv freeplane.zip /opt
    - Dézipper Freeplane => unzip Freeplane.zip
    - Créer un lien vers le répertoire Freeplanexx => ln nsf freeplane-x freeplane
    - Pour une première installation, il faut créer le fichier freeplane.desktop dans le répertoire utilisateur : nano /home/user/.local/share/applications/freeplane.desktop
    Puis insérer le code suivant :
    [Desktop Entry]
    Version=1,0
    Encoding=UTF-8
    Name=Freeplane
    Exec=/bin/sh/opt/freeplane/freeplane.sh %f
    Terminal=false
    Icon=/opt/freeplane/freeplane.svg
    Type=Application
    MimeType=application/x-freemind
    Categories=Application;Office,
    GenericName=Freeplane

    Le logiciel fonctionne correctement mais il est lent au démarrage.
    Une apppli standard démarre en moins d'une seconde.
    Freeplane démare en 5 à 10 secondes.

    Code:
    java -version
    openjdk version "10.0.1" 2018-04-17
    OpenJDK Runtime Environment (build 10.0.1+10-suse-lp150.1.11-x8664)
    OpenJDK 64-Bit Server VM (build 10.0.1+10-suse-lp150.1.11-x8664, mixed mode)
    Je suspecte Java mais entre java, jdk et jre je suis un peu perdu..
    Une incompatibilité entre FP et OSL ?

    Cdt
    VGA compatible controller : NVIDIA corporation GK 20 [GeForce GT730] (rev a1)
    LEAP 15.0

  2. #2
    Caméléon bavard Avatar de tristan
    Inscrit
    mars 2013
    Lieu
    Digne-les-Bains
    Distribution
    Debian 9
    Environnement
    Plasma 5.8
    Messages
    769
    Salut,
    Je n'a jamais remarqué la chose que ce soit sur Debian ou openSUSE. Après c'est vrai qu'il est rare que j'installe des applis comme ceci. Je me contente généralement des dépôts mis à disposition sur opensuse (packman compris) ou du one click install. Voire flatpack à présent. (Spotify) (backports si nécesaire sous Debian)
    Ce logiciel nécessite tout simplement peut être beaucoup de ressources ?
    Lance le dans un terminal pour voir ?
    Dernière édition par tristan; 09/07/2018 à 10h52

  3. #3
    Caméléon sympa Avatar de sogal
    Inscrit
    octobre 2016
    Lieu
    Isère
    Distribution
    openSUSE Leap 42.3 (64 bits)
    Environnement
    Gnome
    Messages
    461
    Il faudrait voir en terminal en effet.
    Si c'est du Java, ça implique que la machine virtuelle Java démarre avant qu'elle puisse démarrer ton appli, ça ne paraît pas déconnant selon le matériel (disque méca, fréquence RAM etc...)
    Machine pro : Thinpad T450 openSUSE Leap 42.3 | Machine perso : Thinkpad x230 openSUSE Leap 42.3 | Workstation hyperviseur: guess what ?

  4. #4
    Nouveau caméléon
    Inscrit
    janvier 2018
    Distribution
    opensuse leap 15.0
    Environnement
    KDE
    Messages
    118
    Citation Envoyé par tristan Voir le message
    Lance le dans un terminal pour voir ?
    Bonjour,

    Voila ce que ca donne.
    Code:
    WARNING: An illegal reflective access operation has occurred
    WARNING: Illegal reflective access by org.freeplane.launcher.Launcher (file:/opt/freeplane-1.6.15/freeplanelauncher.jar) to field sun.awt.X11.XToolkit.awtAppClassName
    WARNING: Please consider reporting this to the maintainers of org.freeplane.launcher.Launcher
    WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
    WARNING: All illegal access operations will be denied in a future release
    org.knopflerfish.framework.readonly=true
    org.knopflerfish.gosg.jars=reference:file:/opt/freeplane-1.6.15/core/
    org.freeplane.user.dir=/opt/freeplane-1.6.15
    org.freeplane.basedirectory=/opt/freeplane-1.6.15
    java.security.policy=/opt/freeplane-1.6.15/freeplane.policy
    org.osgi.framework.storage=/opt/freeplane-1.6.15/fwdir
    Knopflerfish OSGi framework launcher, version <unknown>
    Copyright 2003-2017 Knopflerfish. All Rights Reserved.
    See http://www.knopflerfish.org for more information.
    
    Created Framework: org.knopflerfish.framework, version=8.0.4.
    Installed: reference:file:/opt/freeplane-1.6.15/plugins/org.freeplane.plugin.bugreport (id#2)
    Installed: reference:file:/opt/freeplane-1.6.15/plugins/org.freeplane.plugin.formula (id#3)
    Installed: reference:file:/opt/freeplane-1.6.15/plugins/org.freeplane.plugin.jsyntaxpane (id#4)
    Installed: reference:file:/opt/freeplane-1.6.15/plugins/org.freeplane.plugin.latex (id#5)
    Installed: reference:file:/opt/freeplane-1.6.15/plugins/org.freeplane.plugin.openmaps (id#6)
    Installed: reference:file:/opt/freeplane-1.6.15/plugins/org.freeplane.plugin.script (id#7)                                                                                        
    Installed: reference:file:/opt/freeplane-1.6.15/plugins/org.freeplane.plugin.svg (id#8)                                                                                           
    Started: reference:file:/opt/freeplane-1.6.15/plugins/org.freeplane.plugin.bugreport (id#2)                                                                                       
    Started: reference:file:/opt/freeplane-1.6.15/plugins/org.freeplane.plugin.formula (id#3)
    Started: reference:file:/opt/freeplane-1.6.15/plugins/org.freeplane.plugin.jsyntaxpane (id#4)
    Started: reference:file:/opt/freeplane-1.6.15/plugins/org.freeplane.plugin.latex (id#5)
    Started: reference:file:/opt/freeplane-1.6.15/plugins/org.freeplane.plugin.openmaps (id#6)
    Started: reference:file:/opt/freeplane-1.6.15/plugins/org.freeplane.plugin.script (id#7)
    Started: reference:file:/opt/freeplane-1.6.15/plugins/org.freeplane.plugin.svg (id#8)
    juil. 09, 2018 5:38:02 PM org.freeplane.core.util.LogUtils info
    INFOS: freeplane_version = 1.6.15; freeplane_xml_version = freeplane 1.6.0
    git revision = fe0b3d3c7f05668d40ca1433346f5bec92e26743 Dimitry Polivaev 2018-05-13T15:41:44Z
    java_version = 10.0.1; os_name = Linux; os_version = 4.12.14-lp150.12.4-default
    juil. 09, 2018 5:38:04 PM org.freeplane.core.util.LogUtils info
    INFOS: available locales not found
    juil. 09, 2018 5:38:04 PM org.freeplane.core.util.LogUtils info
    INFOS: available locales not found
    juil. 09, 2018 5:38:07 PM org.freeplane.core.util.LogUtils info
    INFOS: Loaded properties from bundle://3:1/org/freeplane/plugin/formula/defaults.properties
    juil. 09, 2018 5:38:07 PM org.freeplane.core.util.LogUtils info
    INFOS: extending script's classpath by [/home/eric/.config/freeplane/1.6.x/lib]
    juil. 09, 2018 5:38:07 PM org.freeplane.core.util.LogUtils info
    INFOS: Loaded properties from bundle://7:1/org/freeplane/plugin/script/defaults.properties
    juil. 09, 2018 5:38:07 PM org.freeplane.core.util.LogUtils info
    INFOS: looking for scripts with the following endings: [js, groovy]
    
    STDOUT: Framework launchedjuil. 09, 2018 5:38:09 PM org.freeplane.core.util.LogUtils info
    INFOS: requesting mode: MindMap
    juil. 09, 2018 5:38:14 PM org.freeplane.core.util.LogUtils info
    INFOS: menu items to execute: []
    Ceci dit, hors mis la longueur de démarrage, sur clic droit, freeze du programme.

    J'ai installé java1_8.jdk et depuis je n'ai plus de freeze.

    Je ne peux pas dire que le démarrage soit très violent, mais au moins ca fonctionne.

    Mais comme j'y suis allé à l'intuition, j'essaie de comprendre.
    J'avais un java 10-1 et la c'est un 10-8. Je trouve une cohérence puisqu'il me semble que la version actuelle de java est 8.
    La ou je comprends pas, c'est pourquoi freeplane semble utiliser 10-1. De plus, il utilise 10-1 mais si 10-8 est pas installé il plante.

    Je comprends pas trop :-(
    VGA compatible controller : NVIDIA corporation GK 20 [GeForce GT730] (rev a1)
    LEAP 15.0

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé