Page 1 sur 2 12 DernièreDernière
Affiche les résultats de 1 à 10 sur 20

Sujet : TUMBLEWEED remplace LEAP 15.0 après installation GIMP2.10

  1. #1
    Nouveau caméléon
    Inscrit
    avril 2008
    Lieu
    Ain
    Distribution
    Opensuse Leap 15.0
    Environnement
    KDE Plasma
    Messages
    194

    TUMBLEWEED remplace LEAP 15.0 après installation GIMP2.10

    Bonjour à tous.
    J'ai voulu installer GIMP 2.10 sur mon OS LEAP 15.0.
    Je n'ai seulement pas fait attention que la page concernait la Tumbleweed... J'ai donc cliqué sur le bouton d'installation en toute confiance.
    Même pas étonné d'un message m'annonçant 2700 et quelques paquets à mettre à jour (à 2h du matin suis-je excusable ?).
    Et c'est parti !
    Tout content d'avoir enfin GIMP 2.10, j'ai déchanté à l'arrêt de mon PC, lorsque la fenêtre TUMBLEWEED s'affiche juste avant l'extinction.
    De plus, au redémarrage ce matin, une fenêtre console proposant des trucs MOP ou quelque chose comme ça s'est affichée avant le grub. La TUMBLEWEED a cependant démarré normalement.

    D'où ma question : il doit être possible de faire machine arrière et revenir sur la LEAP 15 avec zypper (-dup ?) mais je ne sais pas trop comment m'y prendre...
    A moins que la réinstallation soit la seule option ?

    Je compte sur vos lumières....
    Merci par avance et bonne journée.

    Laudo

  2. #2
    Grand caméléon Modérateur Avatar de jtro
    Inscrit
    dcembre 2009
    Lieu
    Pornichet,Bangkok,Almunecar
    Distribution
    leap 15.1 +Tumbleweed
    Environnement
    gnome3 + LXQT
    Messages
    3 017
    Remettre les adresses leap 15 au lieu de tumbleweed pour les dépôts et refaire un zypper duo.
    Ceci dit,passer de leap 15 à tumbleweed sans s'en apercevoir,faut l'faire!

  3. #3
    Caméléon sympa
    Inscrit
    octobre 2014
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE
    Messages
    309
    si tu est en btrfs tu peux peut revenir très facilement boot from snapshot -> tu peux booté sur un ancien cliché en lecture seul.
    une foie que à booté sur un clicher qui conviens tu il suffit d'utiliser la commande "snapper rollback" pour reprendre le cliché

    Arprès sur leap tu fait la mis à jour avec "zypper up". La commande "zypper dup", sur leap autorise le changement de dépôts sauf utilisé avec l'option "--no-allow-vendor-change"

  4. #4
    Nouveau caméléon
    Inscrit
    avril 2008
    Lieu
    Ain
    Distribution
    Opensuse Leap 15.0
    Environnement
    KDE Plasma
    Messages
    194
    Citation Envoyé par jtro Voir le message
    Remettre les adresses leap 15 au lieu de tumbleweed pour les dépôts et refaire un zypper duo.
    Bonjour jtro,
    merci pour ta réponse.
    J'ai toujours les dépôts de la 15. Je suppose qu'il suffit de désactiver le dépôt Tumbleweed et lancer zypper dup ?

    Citation Envoyé par jtro Voir le message
    Ceci dit,passer de leap 15 à tumbleweed sans s'en apercevoir,faut l'faire!
    Ah mais j'aurais voulu le faire que je n'y serais pas arrivé !
    Comme dit dans le premier post : je trouvais très bizarre la mise à jour de plus de 2700 paquets...
    Honte à moi.

    Merci encore pour ta réponse.
    Bonne journée.

  5. #5
    Nouveau caméléon
    Inscrit
    avril 2008
    Lieu
    Ain
    Distribution
    Opensuse Leap 15.0
    Environnement
    KDE Plasma
    Messages
    194
    Citation Envoyé par david Voir le message
    si tu est en btrfs tu peux peut revenir très facilement boot from snapshot -> tu peux booté sur un ancien cliché en lecture seul.
    une foie que à booté sur un clicher qui conviens tu il suffit d'utiliser la commande "snapper rollback" pour reprendre le cliché

    Arprès sur leap tu fait la mis à jour avec "zypper up". La commande "zypper dup", sur leap autorise le changement de dépôts sauf utilisé avec l'option "--no-allow-vendor-change"
    Bonjour David,
    merci pour ton message mais après avoir lu plusieurs infos sur ce partitionnement, je n'ai pas choisi le btrfs. Pas osé :-).
    Pourtant ça a l'air plutôt pratique en cas de fausse manip'...

    Et merci pour la commande zypper up, le "d" n'est pas nécessaire.

    Bonne journée.

  6. #6
    Nouveau caméléon
    Inscrit
    avril 2008
    Lieu
    Ain
    Distribution
    Opensuse Leap 15.0
    Environnement
    KDE Plasma
    Messages
    194
    @jtro et David : je teste vos recommandations et reviens marquer le sujet en résolu si c'est tout bon.
    Merci encore à vous.

  7. #7
    Caméléon sympa
    Inscrit
    octobre 2014
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE
    Messages
    309
    l'autre solution : c'est tu vas dans yast -> dépôts logiciel
    assure toi que Tu es les 4 dépots d'opensuse Leap 15(oss, non-oss, update oss, update non-os) tu trouvera les adresse ici :https://en.opensuse.org/Package_repositories
    supprime tout les dépôts qui contienne tumbleweed

    après soie tu fait un "zypper dup"
    Mais la solution que j’utiliserai :
    va dans yast -> installer supprimer des logiciels
    affiche les paket par dépots. sélectionne le dépôts oss et click sur rempacer les paquets système par les version de ce dépôts. recommence avec le dépôts update-oss, dans cette ordre
    fait de même avec les dépôts non oss

    puis sélectionne @system les pakets installer tu aura une liste qui vont appaire en rouge, c'est les packets qui se sont plus sur dépôts activé supprime les (sauf les programmes installer avec avec rpm)

    puis lance l'instalation.
    une foi terminé, redémarre est lance la commande zypper inr pour installer les packets recommandé manquante

  8. #8
    Grand caméléon Modérateur Avatar de jtro
    Inscrit
    dcembre 2009
    Lieu
    Pornichet,Bangkok,Almunecar
    Distribution
    leap 15.1 +Tumbleweed
    Environnement
    gnome3 + LXQT
    Messages
    3 017
    Oui bien vérifier tes dépôts avant de faire quoique ce soit. Sinon,la méthode zypper dup ça va quand même plus vite
    Dernière édition par jtro; 25/07/2018 à 13h43

  9. #9
    Caméléon sympa
    Inscrit
    octobre 2014
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE
    Messages
    309
    le problème de zypper dup, c'est qui prend les soft dans la version la plus récente quelle soie le dépôts. je préférer utilise les dépôts officiels tans que c'est possible

    tu as toujours la zypper dup --from <non du dépots> pour forcé sur un dépots particulier

  10. #10
    Nouveau caméléon
    Inscrit
    avril 2008
    Lieu
    Ain
    Distribution
    Opensuse Leap 15.0
    Environnement
    KDE Plasma
    Messages
    194
    Merci pour vos compléments d'info.

    Voici comment j'ai procédé :
    1. - désactivation du dépôt Tumbleweed dans Yast
    2. - en console :
      • zypper ref
      • zypper up : m'a indiqué "Rien à faire"......?
      • j'ai donc lancé : zypper dup --no-allow-vendor-change
      • zypper m'a retourné 5 pb avec des paquets (relatifs à gimp 2.10) pour lesquels j'ai choisi une version plus ancienne


    et depuis ça tourne. J'en suis, au moment où j'écris, à 450 paquets téléchargés sur 2483 !

    Ce qui m'inquiète c'est cette fenêtre console tout au démarrage du PC...J'espère que ça va rétablir le fonctionnement initial. Mais ne crions pas avant d'avoir mal :-).
    Je vous tiens au courant dans un moment...

    Merci encore à vous.

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé