Page 1 sur 2 12 DernièreDernière
Affiche les résultats de 1 à 10 sur 18

Sujet : gscan2pdf, fonctionne partout sauf chez opensuse

  1. #1
    Léon Avatar de thierryR
    Inscrit
    janvier 2013
    Lieu
    Chalons en Champagne
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE 5
    Messages
    83

    gscan2pdf, fonctionne partout sauf chez opensuse

    Bonjour. Je ne comprends pas bien la politique d'opensuse. Il existe de belles applications, mais elles sont délaissées par opensuse.
    gscan2pdf en est une. Pour les autres je vais ouvrir des fils différents.
    On commence par Aller ici : https://software.opensuse.org/packag...term=gscan2pdf
    puis on essaie.....
    Résultat:

    # gscan2pdf
    Can't locate Set/IntSpan.pm in @INC (you may need to install the Set::IntSpan module) (@INC contains: /usr/lib/perl5/site_perl/5.26.2/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.26.2 /usr/lib/perl5/vendor_perl/5.26.2/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.26.2 /usr/lib/perl5/5.26.2/x86_64-linux-thread-multi /usr/lib/perl5/5.26.2 /usr/lib/perl5/site_perl) at /usr/lib/perl5/vendor_perl/5.26.2/Gscan2pdf/Document.pm line 33.
    BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.26.2/Gscan2pdf/Document.pm line 33.
    Compilation failed in require at /usr/bin/gscan2pdf line 47.
    BEGIN failed--compilation aborted at /usr/bin/gscan2pdf line 47.

    Pour le petit nouveau que je suis, je me demande comment sont maintenus les paquets?
    Pourtant je suis un vieux routard de linux. Ce programme fonctionne partout ailleurs. étonnant non ?

    Ne m'en voulez pas pour ce ton un tantinet provocateur. C'est d'une part dans ma nature et ensuite c'est pour faire évoluer la chose.
    Merci.
    NB: Y a t-il un bug-suse.org quelque part ?

  2. #2
    Grand caméléon Avatar de sobkowiak
    Inscrit
    septembre 2010
    Lieu
    Châtas 88
    Distribution
    Leap 15.0
    Environnement
    Plasma 5
    Messages
    3 639
    J'ai installé gscan2pdf depuis le dépôt, et il fonctionne.

    Screenshot_20180812_192612.jpg

  3. #3
    Léon Avatar de thierryR
    Inscrit
    janvier 2013
    Lieu
    Chalons en Champagne
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE 5
    Messages
    83
    Serait ce parce que nous ne sommes pas sur les mêmes distribs ?

  4. #4
    Grand caméléon Avatar de sobkowiak
    Inscrit
    septembre 2010
    Lieu
    Châtas 88
    Distribution
    Leap 15.0
    Environnement
    Plasma 5
    Messages
    3 639
    Je suis sur Leap 15.0 avec Plasma 5. Mais il est exact qu'on ne peut l'installer sur Tumbleweed par manque de perl GTK 2-ex-simple-list

  5. #5
    Administrateur Administrateur Avatar de sogal
    Inscrit
    octobre 2016
    Lieu
    Isère
    Distribution
    openSUSE Leap 15.0 (64 bits)
    Environnement
    Gnome
    Messages
    584
    Il s'agît sûrement d'un bug dans la gestion des dépendances pour Tumbleweed. Il suffit de faire un rapport de bug et d'attendre que son mainteneur corrige le soucis.
    La politique d'empaquetage est assez simple : s'il y a un mainteneur, il y aura un paquet
    Machine perso : Thinkpad x230 : Leap 15.0 | Workstation hyperviseur: Leap 15.0

  6. #6
    Léon Avatar de thierryR
    Inscrit
    janvier 2013
    Lieu
    Chalons en Champagne
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE 5
    Messages
    83
    C'est où qu'on fait un rapport de bug ?

  7. #7
    Administrateur Administrateur Avatar de sogal
    Inscrit
    octobre 2016
    Lieu
    Isère
    Distribution
    openSUSE Leap 15.0 (64 bits)
    Environnement
    Gnome
    Messages
    584
    C'est par ici : https://bugzilla.opensuse.org
    Renseigne bien ta distribution (openSUSE Tumbleweed) et le nom du paquet ainsi qu'éventuellement son dépôt d'origine si tu l'as installé depuis un dépôt en particulier.
    Colle ensuite le message d'erreur que tu as obtenu.
    Attention: les bugs sont à renseigner en anglais car les mainteneurs des paquets peuvent de toutes nationalités. Si tu as des difficultés avec cette langue on t'aidera.
    Machine perso : Thinkpad x230 : Leap 15.0 | Workstation hyperviseur: Leap 15.0

  8. #8
    Léon Avatar de thierryR
    Inscrit
    janvier 2013
    Lieu
    Chalons en Champagne
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE 5
    Messages
    83
    Voila c'est fait: Bugzilla – Bug 1104981 Submitted

  9. #9
    Administrateur Administrateur Avatar de sogal
    Inscrit
    octobre 2016
    Lieu
    Isère
    Distribution
    openSUSE Leap 15.0 (64 bits)
    Environnement
    Gnome
    Messages
    584
    Cool, je vois que l'on t'a déjà répondu. Visiblement il te faut ajouter les modules Perl manquants.
    Machine perso : Thinkpad x230 : Leap 15.0 | Workstation hyperviseur: Leap 15.0

  10. #10
    Caméléon sympa Avatar de Mister-Magoo
    Inscrit
    octobre 2005
    Lieu
    Nord Isère
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    Plasma 5
    Messages
    457
    En ajoutant les 2 ou 3 modules manquants à la main, ça passe.
    C'est agaçant, mais ça marche...

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé