Affiche les résultats de 1 à 5 sur 5

Sujet : lié un dossier du /home avec apache

  1. #1
    Léon Avatar de thierryR
    Inscrit
    janvier 2013
    Lieu
    Chalons en Champagne
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE 5
    Messages
    83

    lié un dossier du /home avec apache

    Bonjour. J'ai installé apache2 et phpmyadmin. Tout roule.

    Maintenant je veux faire fonctionner des fichiers depuis mon /home.
    J'ai donc créé un lien symbolique
    Code:
    # ln -s /home/moi/php /srv/www/htdocs/
    
    Dans mon dossier php j'ai déjà mis un fichier index.php mais

    http://localhost/php/ me retourne une erreur 403.

    Dans /srv/www/htdocs/php j'ai ceci:
    Code:
     ls -la
    total 16
    drwxrwxrwx  3 thierry users 4096 15 août  23:41 .
    drwxr-xr-x 44 thierry users 4096 15 août  23:29 ..
    drwxrwxrwx  9 thierry users 4096 25 mars  18:21 asseleci
    -rw-rw-rw-  1 thierry users   28 15 août  23:41 index.php
    Tous les droits étant ouvert, je ne comprends pas pourquoi ça ne veut pas fonctionner.
    J'ai rajoute thierry au groupe wwwrun

    Si quelqu'un a une idée. Merci.

  2. #2
    Caméléon sympa
    Inscrit
    octobre 2014
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE
    Messages
    312
    le plus simple est de crée un alias dans la configuartion apache2:
    Alias /php/ "/home/moi/php/"
    <Directory "/home/moi/php">
    Require all granted
    </Directory>
    La ligne Alias crée l'alias.
    la zone Directory permet de géré les options du répertoire.
    l'option Require all granted permet d'autorisé apache à lire le répertoire.

    pour se faire le plus simpe va dans yast -> serveur HTTP
    va dans l'onglet hôte principal
    click ajouter -> Alias puis entre en paramétre /php/ "/home/moi/php/"
    click ajouter -> Directory dans la fenêtre qui s'ouvre entre "/home/moi/php" comme répertoire et ajoute Require all granted comme tu l'a fait Alias /php/ "/home/moi/php/" dans la fenêtre hôte principale
    ferme la fenêtre du répertoire et de yast http serveur. puis redémmare apache2 (rcapache2 restart)

    normalement sa devrais fonctionner.
    si tu veux ajoute d'autre options dans la fenetre du répetoire comme Options Indexes pour ajouté l'index du réperoire.
    fait un toure sur https://httpd.apache.org/docs/2.4/fr/ pour voire tout les options/possiblité de apache

  3. #3
    Administrateur Administrateur Avatar de sogal
    Inscrit
    octobre 2016
    Lieu
    Isère
    Distribution
    openSUSE Leap 15.0 (64 bits)
    Environnement
    Gnome
    Messages
    621
    Salut,
    Vérifie également que le module "userdir" est activé.
    Pour lister les modules Apache chargé :

    Code:
    apachectl -M
    Machine perso : Thinkpad x230 : Leap 15.0 | Workstation hyperviseur: Leap 15.0

  4. #4
    Léon Avatar de thierryR
    Inscrit
    janvier 2013
    Lieu
    Chalons en Champagne
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE 5
    Messages
    83
    @david: j'ajoute bien un Alias mais lorsque je met la nouvelle directory, alias disparait ???
    @Sogal:
    apachectl -M
    Absolute path to 'apachectl' is '/usr/sbin/apachectl', so running it may require superuser privileges (eg. root).
    Je ne trouve pas de RPM userdir.

  5. #5
    Administrateur Administrateur Avatar de sogal
    Inscrit
    octobre 2016
    Lieu
    Isère
    Distribution
    openSUSE Leap 15.0 (64 bits)
    Environnement
    Gnome
    Messages
    621
    Ce n'est pas un RPM mais un module natif pas forcément activé par défaut car ça peut être une faille de sécurité.
    As-tu fait que ce te renvoie la commande à savoir relancer la commande en tant que root (ou avec sudo : sudo apachectl -M) ?
    Machine perso : Thinkpad x230 : Leap 15.0 | Workstation hyperviseur: Leap 15.0

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé