Page 1 sur 2 12 DernièreDernière
Affiche les résultats de 1 à 10 sur 15

Sujet : Configuration scanner imprimante multifonction samsung SCX-3205

  1. #1
    Léon
    Inscrit
    aot 2018
    Distribution
    OpenSUSE Leap 15
    Environnement
    KDE
    Messages
    8

    Configuration scanner imprimante multifonction samsung SCX-3205

    Bonjour à tous,

    Petite présentation rapide, je suis un utilisateur de Suse depuis la 6.quelque chose, à l'époque où on avait une belle boîte toute verte, un gros livre et tout plein de CD. Je suis resté en double boot pendant assez longtemps (à cause du gaming) et suis passé au full linux depuis environ 5 ans. Je fais un peu de tout et pas mal de gaming (steam linux principalement).

    Pour ce qui est du soucis qui m’amène vers vous, pas moyen de configurer/utiliser le scanner de mon imprimante multifonction samsung SCX-3205 (pour la fonction imprimante pas de soucis).

    La scanner fonctionne sans problème sous leap 42.3 (sur un portable) mais impossible de l'utiliser sous leap 15, et cela sur 2 postes fixes (cartes mères différentes) et sur un autre portable.

    Le dmesg suite au branchement du scanner est le suivant

    [17212.181124] usb 1-11: new high-speed USB device number 11 using xhci_hcd
    [17212.329916] usb 1-11: New USB device found, idVendor=04e8, idProduct=3441
    [17212.329923] usb 1-11: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [17212.329927] usb 1-11: Product: SCX-3200 Series
    [17212.329931] usb 1-11: Manufacturer: Samsung Electronics Co., Ltd.
    [17212.329934] usb 1-11: SerialNumber: Z5EXBFCBA02233T
    [17212.364047] usblp 1-11:1.1: usblp0: USB Bidirectional printer dev 11 if 1 alt 0 proto 2 vid 0x04E8 pid 0x3441
    [17212.364063] usbcore: registered new interface driver usblp
    [17217.465898] usblp0: removed
    [17217.466933] usblp 1-11:1.1: usblp0: USB Bidirectional printer dev 11 if 1 alt 0 proto 2 vid 0x04E8 pid 0x3441
    Le "usblp0: removed" est probablement en rapport avec le soucis.

    scanimage -L détecte bien le scanner la première fois, mais pas les fois suivantes.

    user@ordi:~> scanimage -L
    device `xerox_mfp:libusb:001:011' is a Samsung Samsung SCX-3200 Series multi-function peripheral
    user@ordi:~> scanimage -L

    No scanners were identified. If you were expecting something different,
    check that the scanner is plugged in, turned on and detected by the
    sane-find-scanner tool (if appropriate). Please read the documentation
    which came with this software (README, FAQ, manpages).

    J'ai trouvé un post de 2015 avec le même symptôme, mais ça m'a pas aidé beaucoup .... https://forums.opensuse.org/showthread.php/504397-USB-Scanner-disappears-after-some-seconds-of-system-runtime

    Je me suis dit de mettre une version précédente de usbcore ou usblp, mais j'ai l'impression que c'est intégré au noyau, et j'ai pas la compétence de trifouiller la dedans.

    Donc voilou, si quelqu'un peut m'aider ça serait bien gentil

  2. #2
    Grand caméléon Avatar de sobkowiak
    Inscrit
    septembre 2010
    Lieu
    Châtas 88
    Distribution
    Leap 15.0
    Environnement
    Plasma 5
    Messages
    3 633
    Dans Yast->scanneur, on trouve un pilote pour votre imprimante-scanner. Vous l'avez essayé ?

  3. #3
    Léon
    Inscrit
    aot 2018
    Distribution
    OpenSUSE Leap 15
    Environnement
    KDE
    Messages
    8
    Oui, oui, c'est le xerox_mfp je pense, mais une fois sélectionné ça me dit "Ce pilote ne reconnaît aucun scanneur".

    J'ai aussi fait divers essai avec le pilote de chez Samsung (Samsung Unified Linux Driver) mais ça change rien.

    A mon avis le problème se trouve plus bas niveau, doit y avoir un soucis avec l'usb, du coup le driver n'a même pas accès au scanner.

  4. #4
    Léon Avatar de thierryR
    Inscrit
    janvier 2013
    Lieu
    Chalons en Champagne
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE 5
    Messages
    83
    Souvent les scanners fonctionnent également sans fil. En débranchant ton imprimante, est ce que tu y accèdes toujours ? ( C'est pour répondre au problème de l'USB)

  5. #5
    Léon
    Inscrit
    aot 2018
    Distribution
    OpenSUSE Leap 15
    Environnement
    KDE
    Messages
    8
    Merci, mais c'est une imprimante usb, sans sans fil quoi

  6. #6
    Léon
    Inscrit
    aot 2018
    Distribution
    OpenSUSE Leap 15
    Environnement
    KDE
    Messages
    8
    Bonjour,

    Toujours pas moyen de faire fonctionner ce scanner :(

    La commande sudo sane-find-scanner me retourne

    Code:
      # sane-find-scanner will now attempt to detect your scanner. If the
      # result is different from what you expected, first make sure your
      # scanner is powered up and properly connected to your computer.
    
      # No SCSI scanners found. If you expected something different, make sure that
      # you have loaded a kernel SCSI driver for your SCSI adapter.
    
    found USB scanner (vendor=0x04e8 [Samsung Electronics Co., Ltd.], product=0x3441 [SCX-3200 Series]) at libusb:001:014
    could not fetch string descriptor: Pipe error
    could not fetch string descriptor: Pipe error
      # Your USB scanner was (probably) detected. It may or may not be supported by
      # SANE. Try scanimage -L and read the backend's manpage.
    
      # Not checking for parallel port scanners.
    
      # Most Scanners connected to the parallel port or other proprietary ports
      # can't be detected by this program.
    Est-ce que "could not fetch string descriptor: Pipe error" pourrait être en rapport avec le soucis ?

  7. #7
    Grand caméléon Avatar de sobkowiak
    Inscrit
    septembre 2010
    Lieu
    Châtas 88
    Distribution
    Leap 15.0
    Environnement
    Plasma 5
    Messages
    3 633
    Merci, mais c'est une imprimante usb, sans sans fil quoi
    Une imprimante usb est reliée au pc avec un câble usb, sinon c'est du wifi.

  8. #8
    Léon
    Inscrit
    aot 2018
    Distribution
    OpenSUSE Leap 15
    Environnement
    KDE
    Messages
    8
    Citation Envoyé par sobkowiak Voir le message
    Une imprimante usb est reliée au pc avec un câble usb, sinon c'est du wifi.
    Oui oui, il s'agit d'une imprimante usb relié au pc avec un cable usb.

  9. #9
    Grand caméléon Avatar de sobkowiak
    Inscrit
    septembre 2010
    Lieu
    Châtas 88
    Distribution
    Leap 15.0
    Environnement
    Plasma 5
    Messages
    3 633
    Vous êtes passé par Yast->Matériel->scanner (et non imprimante) ? S'il est allumé, il doit apparaître comme non configuré. S'il n'y a rien, c'est vraisemblablement un souci de branchement.

  10. #10
    Léon
    Inscrit
    aot 2018
    Distribution
    OpenSUSE Leap 15
    Environnement
    KDE
    Messages
    8
    Citation Envoyé par sobkowiak Voir le message
    Vous êtes passé par Yast->Matériel->scanner (et non imprimante) ? S'il est allumé, il doit apparaître comme non configuré. S'il n'y a rien, c'est vraisemblablement un souci de branchement.
    Merci pour la suggestion, mais j'ai déjà essayé.

    Avant tout accès au scanner (au démarrage de l'ordi par exemple) un premier lancement de yast-scanner fonctionne correctement (détection du scanner et choix du bon driver). Je valide la page avec "ok".
    yast1.png

    Je relance immédiatement yast-scanner sans avoir fait aucune autre action, et j'ai alors la page suivante.

    yast2.png

    De la même façon, 2 lancements successifs de "scanimage -L" entraîne une perte de la détection du scanner. (voir mon 1er post).

    Je n'ai pas de soucis avec leap 42.3 mais seulement avec des ordi sous leap 15.

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé