Page 1 sur 3 123 DernièreDernière
Affiche les résultats de 1 à 10 sur 27

Sujet : Impossible de démarrer Leap 15.0 sans le CD d'installation

  1. #1
    Léon
    Inscrit
    dcembre 2015
    Lieu
    La Tour-de-Peilz, Suisse
    Distribution
    openSUSE Leap 42.3 (64 bits)
    Environnement
    KDE
    Messages
    34

    Impossible de démarrer Leap 15.0 sans le CD d'installation

    Bonjour à tous,
    Je viens d'installer Leap 15.0 sur un PC (SSD vierge) en acceptant toutes les propositions faites par l'installateur, sans rien modifier. Mais je ne peux pas démarrer à partir du disque local sans utiliser le CD d'installation. Je n'ai jamais eu un tel problème!
    Apparemment, le gestionnaire d'amorçage n'est pas placé au bon endroit. Comme je suis un béotien en la matière, comment dois-je faire pour résoudre ce problème?
    Avec mes remerciements anticipés pour vos réponses.

  2. #2
    Caméléon sympa Avatar de Bernado82
    Inscrit
    janvier 2016
    Lieu
    /home
    Distribution
    openSUSE Leap 15.1
    Environnement
    KDE Plasma 5.15
    Messages
    341
    Bonjour!

    Es-ce que tu veux dire que, par exemple, si le DVD d'installation n'est pas présent dans le lecteur, tu as à l'écran un message du BIOS genre "No Boot device"?

    Essayes une réinstallation de Leap en mode "LEGACY" (voir la configuration du BIOS), c'est à dire pas en mode UEFI...

    Sinon, il faudrait relancer YaST --> Chargeur d'amorçage pour y vérifier ou reconfigurer l'emplacement d'amorcage. Ceci pouvant être fait aussi en ligne de commande via Grub.
    https://www.facebook.com/profile.php?id=100011319637977 (page orientée openSuse)
    https://open.spotify.com/user/bernad...eomqM38isNZRIj (playlist Spotify)

    Utilitaires pour Rockchip:
    https://www.mediafire.com/folder/2x8...Rockchip_Tools
    https://mega.co.nz/#F!wxJliCiT!fSTU4uzNwJ4h_ZGOYHcjcQ

    Les outils Rockchip sont parfois moches, voici RK Android Tool v2.3.9 et Driver Assistant v4.5 après mon petit coup de polish:
    https://www.mediafire.com/folder/5qs985buhb8g5/Rockchip

  3. #3
    Léon
    Inscrit
    dcembre 2015
    Lieu
    La Tour-de-Peilz, Suisse
    Distribution
    openSUSE Leap 42.3 (64 bits)
    Environnement
    KDE
    Messages
    34
    Merci pour la réponse.
    Es-ce que tu veux dire que, par exemple, si le DVD d'installation n'est pas présent dans le lecteur, tu as à l'écran un message du BIOS genre "No Boot device"?
    Exact.
    Essayes une réinstallation de Leap en mode "LEGACY" (voir la configuration du BIOS), c'est à dire pas en mode UEFI...
    Mon PC n'a pas de mode UEFI.

    Ne puis-je pas faire cela avec YasT? Mais je n'ai aucune idée!

  4. #4
    Administrateur Administrateur Avatar de sogal
    Inscrit
    octobre 2016
    Lieu
    Isère
    Distribution
    openSUSE Leap 15.0 (64 bits)
    Environnement
    Gnome
    Messages
    584
    Salut,
    Ne peux-tu pas démarrer avec le DVD puis utiliser Yast, ou mieux, directement la console, en tant que root pour :

    Réinstaller grub au bon endroit :

    grub2-install /dev/sda1

    (/!\ ATTENTION le périphérique /dev/sda1 est ici un exemple à adapter à ton système, il s'agît généralement de la partition /boot ou, à défaut, celle /)

    puis reconfigurer grub:

    grub2-mkconfig -o /boot/grub2/grub.cfg
    Machine perso : Thinkpad x230 : Leap 15.0 | Workstation hyperviseur: Leap 15.0

  5. #5
    Caméléon arc-en-ciel
    Inscrit
    dcembre 2004
    Lieu
    France
    Distribution
    Tumbleweed 32, Mageia 6
    Environnement
    MATE, XFCE
    Messages
    7 836
    Billets
    1
    L'emplacement de grub peut être aussi le MBR, puisque l'ordi est en BIOS.
    Avaec un seul disque, et un seul système, l'emplacement de grub2 est :

    /dev/sda
    ou simplement :

    MBR
    Master Boot Record
    Dernière édition par ahlner; 19/09/2018 à 01h15
    Ce qui reste éternellement incompréhensible dans la nature, c'est que l'on puisse la comprendre.
    Albert Einstein

    Etreignez-vous, millions d'êtres.
    Au monde entier ce baiser!
    Seid umschlungen, Millionen.
    Diesen Kuss der ganzen Welt!
    Friedrich Schiller

  6. #6
    Léon
    Inscrit
    dcembre 2015
    Lieu
    La Tour-de-Peilz, Suisse
    Distribution
    openSUSE Leap 42.3 (64 bits)
    Environnement
    KDE
    Messages
    34
    Merci infiniment pour vos réponses.
    Avant d'effectuer une modification, j'ai fait les constatations suivantes:

    J'ai un autre PC sur lequel tourne Leap 42.3.
    Si je vais dans Yast, Configuration du chargeur d'amorçage, options d'amorçage, je vois les options suivantes cochées:
    1. Amorcer à partir de la partition racine
    2. Définr le marqueur 'active' dans la table de partition pour la partition d'amorçage
    3. Ecrire le code générique d'amorçage dans le MBR

    Si je fais de même sur le PC sur lequel j'ai installé Leap 15.0, j'obtiens:
    1. Amorcer à partir du MBR
    2. Définr le marqueur 'active' dans la table de partition pour la partition d'amorçage

    Cela permet-il d'expliquer le problème?

    D'autre part, l'instruction fdisk -l donne le résultat:

    Code:
    Périphérique     Début       Fin  Secteurs Taille Type
    /dev/sda1         2048     18431     16384     8M Amorçage BIOS
    /dev/sda2        18432  83904511  83886080    40G Système de fichiers Linux
    /dev/sda3     83904512 483928063 400023552 190,8G Système de fichiers Linux
    /dev/sda4    483928064 500118158  16190095   7,7G Partition d'échange Linux
    Qu'est-ce que sda1?
    Que dois-je en faire si je réinstalle grub2?
    Dernière édition par Gian-Piero; 19/09/2018 à 14h42

  7. #7
    Caméléon arc-en-ciel
    Inscrit
    dcembre 2004
    Lieu
    France
    Distribution
    Tumbleweed 32, Mageia 6
    Environnement
    MATE, XFCE
    Messages
    7 836
    Billets
    1
    Si je fais de même sur le PC sur lequel j'ai installé Leap 15.0, j'obtiens:
    1. Amorcer à partir du MBR
    2. Définir le marqueur 'active' dans la table de partition pour la partition d'amorçage
    Amorcer à partir du MBR est essentiel
    Le 2 est accessoire
    /dev/sda1 boot : c'est nouveau pour moi, j'ai découvert cela avec Leap 15.
    Comme proposé plus haut par sogal, il faut actualiser "/boot/grub2/grub.cfg" par la commande :

    Code:
     grub2-mkconfig -o /boot/grub2/grub.cfg
    Ensuite dans Yast Amorçage, installer grub2 dans le MBR et Redémarrer pour vérifier.
    Ce qui reste éternellement incompréhensible dans la nature, c'est que l'on puisse la comprendre.
    Albert Einstein

    Etreignez-vous, millions d'êtres.
    Au monde entier ce baiser!
    Seid umschlungen, Millionen.
    Diesen Kuss der ganzen Welt!
    Friedrich Schiller

  8. #8
    Grand caméléon Modérateur Avatar de jtro
    Inscrit
    dcembre 2009
    Lieu
    Pornichet,Bangkok,Almunecar
    Distribution
    leap 15+ Tumbleweed
    Environnement
    gnome3 + LXQT
    Messages
    2 988
    Chez moi,: amorçage à partir d'une partition, marquer cette partition comme active et écrire le code générique d'amorçage dans le MBR. Donc différent de chez ahlner.
    Et ça marche nickel

    Capture d’écran du 2018-09-20 09-49-42.jpg
    Dernière édition par jtro; 20/09/2018 à 09h51

  9. #9
    Grand caméléon Avatar de sobkowiak
    Inscrit
    septembre 2010
    Lieu
    Châtas 88
    Distribution
    Leap 15.0
    Environnement
    Plasma 5
    Messages
    3 639
    Sur mon pc, c'est "démarrer à partir du MBR" et rien d'autre.

  10. #10
    Caméléon arc-en-ciel
    Inscrit
    dcembre 2004
    Lieu
    France
    Distribution
    Tumbleweed 32, Mageia 6
    Environnement
    MATE, XFCE
    Messages
    7 836
    Billets
    1
    Citation Envoyé par Gian-Piero Voir le message
    Merci infiniment pour vos réponses.
    Avant d'effectuer une modification, j'ai fait les constatations suivantes:

    J'ai un autre PC sur lequel tourne Leap 42.3.
    Si je vais dans Yast, Configuration du chargeur d'amorçage, options d'amorçage, je vois les options suivantes cochées:
    1. Amorcer à partir de la partition racine
    2. Définr le marqueur 'active' dans la table de partition pour la partition d'amorçage
    3. Ecrire le code générique d'amorçage dans le MBR

    Si je fais de même sur le PC sur lequel j'ai installé Leap 15.0, j'obtiens:
    1. Amorcer à partir du MBR
    2. Définr le marqueur 'active' dans la table de partition pour la partition d'amorçage

    Cela permet-il d'expliquer le problème?

    D'autre part, l'instruction fdisk -l donne le résultat:

    Code:
    Périphérique     Début       Fin  Secteurs Taille Type
    /dev/sda1         2048     18431     16384     8M Amorçage BIOS
    /dev/sda2        18432  83904511  83886080    40G Système de fichiers Linux
    /dev/sda3     83904512 483928063 400023552 190,8G Système de fichiers Linux
    /dev/sda4    483928064 500118158  16190095   7,7G Partition d'échange Linux
    Qu'est-ce que sda1?
    Que dois-je en faire si je réinstalle grub2?
    Dans Leap démarrée, que raconte :

    Code:
     mount | grep /sd
    Pour ma Leap, j'ai procédé de manière différente : l'installeur voulait une partitioon de boot, qui est absente, car partitionnement simple.
    J'ai choisi "Non géré", et c'est Mageia 6 qui démarre tous les systèmes.
    Après réflexion, il me semble que Leap exige la partition de boot montée :

    /dev/sda1 /boot
    Désolé pour mon manque de précision au #7.
    Ce qui reste éternellement incompréhensible dans la nature, c'est que l'on puisse la comprendre.
    Albert Einstein

    Etreignez-vous, millions d'êtres.
    Au monde entier ce baiser!
    Seid umschlungen, Millionen.
    Diesen Kuss der ganzen Welt!
    Friedrich Schiller

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé