Page 1 sur 3 123 DernièreDernière
Affiche les résultats de 1 à 10 sur 24

Sujet : Probleme d'imprimante brother mfc-j415w

  1. #1
    Léon
    Inscrit
    janvier 2019
    Lieu
    Québec
    Distribution
    openSUSE Leap 15.0 (64 bits)
    Environnement
    KDE
    Messages
    7

    Probleme d'imprimante brother mfc-j415w

    Bonjour, j'ai un souci avec l'imprimante tout en un brother mfc-j415w. J' ai installer les pilotes de l'imprimante de toute les façon... Avec yast2 tout se passe bien et elle indique prêt, mais impossible d'imprimer. Et en ligne de commande avec les pilotes propriétaire il y a une erreurs et le résultat est le même. Est-ce que quelqu'un peut m'aider car je ne suis pas très bon encore avec la ligne de commande.

  2. #2
    Caméléon sympa Avatar de Grenouille
    Inscrit
    octobre 2014
    Lieu
    CH
    Distribution
    15.1
    Environnement
    Plasma & Xfce
    Messages
    434
    Salut, tu peux nous donner le message d'erreur que tu obtiens?

  3. #3
    Léon
    Inscrit
    janvier 2019
    Lieu
    Québec
    Distribution
    openSUSE Leap 15.0 (64 bits)
    Environnement
    KDE
    Messages
    7
    Dabord! merci de me répondre Grenouille. Voila toute la proçédure.

    guy@linux-x4a8:~> sudo su
    [sudo] Mot de passe de root :
    linux-x4a8:/home/guy # cd /home/guy/Téléchargements/MFC-J415W/Linux_rpm/
    linux-x4a8:/home/guy/Téléchargements/MFC-J415W/Linux_rpm # bash linux-brprinter-installer-2.2.1-1
    Input model name ->mfc-j415w

    You are going to install following packages.
    mfcj415wlpr-1.1.3-1.i386.rpm
    mfcj415wcupswrapper-1.1.3-1.i386.rpm
    brscan3-0.2.13-1.x86_64.rpm
    brscan-skey-0.2.4-1.x86_64.rpm
    OK? [y/N] ->y

    rpm -ihv --nodeps --replacefiles --replacepkgs mfcj415wlpr-1.1.3-1.i386.rpm
    Preparing... ################################# [100%]
    Updating / installing...
    1:mfcj415wlpr-1.1.3-1 ################################# [100%]
    rpm -ihv --nodeps --replacefiles --replacepkgs mfcj415wcupswrapper-1.1.3-1.i386.rpm
    Preparing... ########################################
    Updating / installing...
    mfcj415wcupswrapper-1.1.3-1 ########################################
    #
    The security level of AppArmor has been lowered. (aa-complain cups)
    aa-complain cupsd
    Profile for /usr/sbin/cupsd not found, skipping
    Will you specify the Device URI? [Y/n] ->n

    Test Print? [y/N] ->y

    wait 5s.
    lpr -P MFCJ415W /usr/share/cups/data/testprint
    You are going to install following packages.
    brscan3-0.2.13-1.x86_64.rpm
    rpm -ihv --nodeps --replacefiles --replacepkgs brscan3-0.2.13-1.x86_64.rpm
    Preparing... ################################# [100%]
    Updating / installing...
    1:brscan3-0.2.13-1 ################################# [100%]
    You are going to install following packages.
    brscan-skey-0.2.4-1.x86_64.rpm
    rpm -ihv --nodeps --replacefiles --replacepkgs brscan-skey-0.2.4-1.x86_64.rpm
    Preparing... ################################# [100%]
    Updating / installing...
    1:brscan-skey-0.2.4-1 ################################# [100%]
    ln: failed to create symbolic link '/etc/opt/brother/scanner/brscan-skey/brscan_mail.config': File exists
    ln: failed to create symbolic link '/etc/opt/brother/scanner/brscan-skey/brscan_mailmessage.txt': File exists
    ln: failed to create symbolic link '/etc/opt/brother/scanner/brscan-skey/brscan-skey-0.2.4-0.cfg': File exists
    ln: failed to create symbolic link '/usr/bin/brscan-skey': File exists
    warning: %post(brscan-skey-0.2.4-1.x86_64) scriptlet failed, exit status 1
    apt-get install libusb-0.1-4
    Loading repository data...
    Reading installed packages...
    'libusb-0.1-4' not found in package names. Trying capabilities.
    No provider of 'libusb-0.1-4' found.
    Resolving package dependencies...

    Nothing to do.
    Hit Enter/Return key.
    linux-x4a8:/home/guy/Téléchargements/MFC-J415W/Linux_rpm #

  4. #4
    Grand caméléon Avatar de sobkowiak
    Inscrit
    septembre 2010
    Lieu
    Châtas 88
    Distribution
    Leap 15.0
    Environnement
    Plasma 5
    Messages
    3 677
    'libusb-0.1-4' not found in package names.
    Paquet signalé manquant, donc à installer.

  5. #5
    Léon
    Inscrit
    janvier 2019
    Lieu
    Québec
    Distribution
    openSUSE Leap 15.0 (64 bits)
    Environnement
    KDE
    Messages
    7
    Le paquet n'existe pas.Voila le retours.

    linux-x4a8:/home/guy/Téléchargements/MFC-J415W/Linux_rpm # apt-get install libusb-0.1-4
    Loading repository data...
    Reading installed packages...
    'libusb-0.1-4' not found in package names. Trying capabilities.
    No provider of 'libusb-0.1-4' found.
    Resolving package dependencies...

    Nothing to do.
    linux-x4a8:/home/guy/Téléchargements/MFC-J415W/Linux_rpm #

  6. #6
    Caméléon sympa Modérateur Avatar de Bernado82
    Inscrit
    janvier 2016
    Lieu
    /home
    Distribution
    openSUSE Leap 15.1
    Environnement
    KDE Plasma 5.16
    Messages
    390
    Bonjour,

    La librairie libusb-0.1-4 ne semble pas exister, mais certainement remplacée par libusb-0_1-4 présente dans les dépôts officiels. Parfois, les rpm sont conçus pour Fedora et leur installation sur openSuse peut buter sur des problèmes de librairies qui ne sont pas nommées tout à fait pareil entre ces deux distros.

    Autant que possible, il faut essayer de se passer des pilotes propriétaires et se limiter à ce qui est proposé via YaST car sinon on peut tomber sur des problèmes de dépendances de librairies manquantes.

    Donnes le résultat de la commande
    Code:
    rpm -qa | grep libusb-
    ou
    Code:
    zypper search libusb-
    Dernière édition par Bernado82; 23/01/2019 à 13h55
    https://www.facebook.com/profile.php?id=100011319637977 (page orientée openSuse)
    https://open.spotify.com/user/bernad...eomqM38isNZRIj (playlist Spotify)

    Utilitaires pour Rockchip:
    https://www.mediafire.com/folder/2x8...Rockchip_Tools
    https://mega.co.nz/#F!wxJliCiT!fSTU4uzNwJ4h_ZGOYHcjcQ

    Les outils Rockchip sont parfois moches, voici RK Android Tool v2.3.9 et Driver Assistant v4.5 après mon petit coup de polish:
    https://www.mediafire.com/folder/5qs985buhb8g5/Rockchip

  7. #7
    Léon
    Inscrit
    janvier 2019
    Lieu
    Québec
    Distribution
    openSUSE Leap 15.0 (64 bits)
    Environnement
    KDE
    Messages
    7
    voila les retours.

    linux-x4a8:/home/guy # rpm -qa | grep libusb-
    libusb-0_1-4-0.1.13-lp150.1.7.x86_64
    libusb-1_0-0-1.0.21-lp150.1.8.x86_64
    linux-x4a8:/home/guy # zypper search libusb-
    Loading repository data...
    Reading installed packages...

    S | Name | Summary | Type
    ---+------------------------+-------------------------+--------
    i+ | libusb-0_1-4 | libusb-1.0 Compatibil-> | package
    | libusb-0_1-4-32bit | libusb-1.0 Compatibil-> | package
    i+ | libusb-1_0-0 | USB Library | package
    | libusb-1_0-0-32bit | USB Library | package
    | libusb-1_0-devel | USB Library | package
    | libusb-1_0-devel-32bit | USB Library | package
    | libusb-compat-devel | libusb-1.0 Compatibil-> | package
    linux-x4a8:/home/guy #

  8. #8
    Grand caméléon Avatar de sobkowiak
    Inscrit
    septembre 2010
    Lieu
    Châtas 88
    Distribution
    Leap 15.0
    Environnement
    Plasma 5
    Messages
    3 677

  9. #9
    Caméléon sympa Modérateur Avatar de Bernado82
    Inscrit
    janvier 2016
    Lieu
    /home
    Distribution
    openSUSE Leap 15.1
    Environnement
    KDE Plasma 5.16
    Messages
    390
    As-tu installé la librairie libusb-0_1-4, je suppose que oui, ou alors elle l'a été pour résoudre quelques dépendances...

    Si tu ne souhaites pas obtenir de message d'erreur lors du lancement du script de Brother, tu pourrais y modifier les lignes 1392 à 1403 de la façon suivante je suppose:
    Code:
      # install libusb-0_1-4 if not available
    
      libusbchk=$(ls -R /lib /usr/lib /usr/sbin | grep 'libusb-0.1.so.4')
    
      if [ "$libusbchk" = '' ];then
          if [ "$(which apt-get 2>/dev/null)" != '' ];then
          echo apt-get install libusb-0_1-4
          apt-get install libusb-0_1-4
          fi
      fi
    
      # libusb-0_1-4
    Voir aussi peut-être https://forums.opensuse.org/showthre...32#post2870632 et les pages suivantes?

    https://forums.opensuse.org/showthre...87#post2878887
    https://forums.opensuse.org/showthre...04#post2887404

    Dans le cas d'utilisation du pilote fourni par Brother, certains semblent indiquer qu'il faut aussi installer les versions 32 bits de quelques-unes des librairies...

    Et c’est quoi qui marche pas avec cette imprimante, rien, juste l'impression, juste le scanner?

    Une installation par CUPS peut-être?
    Dernière édition par Bernado82; 24/01/2019 à 03h05
    https://www.facebook.com/profile.php?id=100011319637977 (page orientée openSuse)
    https://open.spotify.com/user/bernad...eomqM38isNZRIj (playlist Spotify)

    Utilitaires pour Rockchip:
    https://www.mediafire.com/folder/2x8...Rockchip_Tools
    https://mega.co.nz/#F!wxJliCiT!fSTU4uzNwJ4h_ZGOYHcjcQ

    Les outils Rockchip sont parfois moches, voici RK Android Tool v2.3.9 et Driver Assistant v4.5 après mon petit coup de polish:
    https://www.mediafire.com/folder/5qs985buhb8g5/Rockchip

  10. #10
    Léon
    Inscrit
    janvier 2019
    Lieu
    Québec
    Distribution
    openSUSE Leap 15.0 (64 bits)
    Environnement
    KDE
    Messages
    7
    Oui j'ai installer libusb qui ressemblait a celui manquant mais ça n'a rien changer. Il n'y as aucune erreurs quand j' essai d'imprimer, mais seulement a l'installation. L' imprimante indique quel est prête et quand je fait le test, ça se met dans la file d'attente mais ça n'imprime jamais, et même si j'allume préalablement l'imprimante.

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé