Affiche les résultats de 1 à 10 sur 10

Sujet : Installation pilote carte graphique AMD Radeon HD 5450

  1. #1
    Léon
    Inscrit
    janvier 2019
    Distribution
    openSUSE Leap 15.0 (64 bits)
    Environnement
    KDE
    Messages
    11

    Installation pilote carte graphique AMD Radeon HD 5450

    Bonsoir
    suite aux redémarrages intempestifs de mon ordinateur, j’ai étudié la piste du driver de ma carte graphique ASUS AMD Radeon HD 5450.
    J’ai donc téléchargé le pilote sur le site du fabricant, car je ne l’ai pas retrouvé dans Yast.
    Je l’ai installé via la konsole (commande bash : bash AMD-Catalyst-15.9-Linux-installer-15.201.1151-x86.x86_64.run), et j’obtiens le message suivant :



    error: Detected X Server version 'XServer 1.19.6_64a' is not supported. Supported versions are X.Org 6.9 or later, up to XServer 1.10 (default:v2:x86_64:lib:XServer 1.19.6_64a:non
    e:4.12.14-lp150.12.28-default
    Installation will not proceed.



    Du coup, j’ai regardé dans Yast : j’ai Xorg-x11-driver-video qui date du 31 août 2017, et qui est installé (version 7.6_1-lp150.2.5)
    Et après ? Je ne sais pas… En fait, je ne comprends pas grand’chose à tout cela...Sur les forums anglo-saxons, il y aurait apparemment des problèmes avec les cartes AMD et linux. Peut-être que les redémarrages d’ordi viennent de là…

    Comment installer la dernière version du driver de ma carte graphique ?

    merci !

  2. #2
    Grand caméléon Avatar de sobkowiak
    Inscrit
    septembre 2010
    Lieu
    Châtas 88
    Distribution
    Leap 15.0
    Environnement
    Plasma 5
    Messages
    3 703
    Cela pourrait peut-être vous aider : https://en.opensuse.org/AMD

  3. #3
    Caméléon sympa Modérateur Avatar de chalu
    Inscrit
    mars 2019
    Lieu
    Anjou
    Distribution
    openSUSE Leap 15.1
    Environnement
    KDE celui de leap
    Messages
    285
    Bonjour,
    ce sujet m’interesse car avec une Ati Radeon HD 5470 il est fort possible que je sois obligé d’ajouter un firmware non-free comme sur l’actuelle Debian 9 avec le noyau 4.9
    Sur irc, on m’a parlé du paquet kernel-firmware mais je n’ai pas encore trouvé comment savoir ce qu’il y a dedans et si ça parle d’ati

  4. #4
    Caméléon bavard Modérateur Avatar de passionlinux
    Inscrit
    janvier 2013
    Lieu
    Val d'oise
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE
    Messages
    635
    Alors je sais pas si je peux aider, j'ai toujours eu du ati et jamais mais grand jamais embété sauf sous debian où je dois installer les firmware-nonfree. Sous opensuse rien a faire ça marche out of the box.

    Est ce sur que ça vient de là les redémarrage? Moi quand ça ma fait ça c'est que ma carte me lachait...

  5. #5
    Caméléon sympa Modérateur Avatar de chalu
    Inscrit
    mars 2019
    Lieu
    Anjou
    Distribution
    openSUSE Leap 15.1
    Environnement
    KDE celui de leap
    Messages
    285
    c'est quoi ton modèle de carte ati passionlinux ?
    c'est peut-être comme pour la WiFi, sous Jessie et son noyau il fallait que j'installe un firmware non-free alors que sous stretch rien à faire avec le noyau 4.9

    y-a-t-il l'équivalent de sudo dmesg|grep -i firmware sur openSUSE pour savoir si le système se plaint d'une absence d'un firmware ?

    J'allumerais bien ma VM mais comme c'est du faux matériel ... Il faut que je télécharge un Live pour tester.

    J'ai vu ici qu'il demandait des tests pour la future Leap 15.1 en demandant de reporter les bugs
    j'ai trouvé les notes de version en français de la 15.1 : https://doc.opensuse.org/release-not...USE/Leap/15.1/
    Dernière édition par chalu; 25/03/2019 à 15h27
    PC Portable ACER ASPIRE 5740G - Intel Core i5 430M 2.26GHz - ATI mobility Radeon HD 5470 - 4 GB de ram

  6. #6
    Caméléon bavard Modérateur Avatar de passionlinux
    Inscrit
    janvier 2013
    Lieu
    Val d'oise
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE
    Messages
    635
    Alors celle qui est morte et ne cessait de redemarrer le pc ou de le figé etait une rv740 serie Radeon HD 4000. Un beau jour elle se figa pour ne plus se rallumer (ecran noir) changé par une simple AMD® Caicos Radeon HD 8000 mais je suis plus trop sur car j'ai jeté la boite

    La commande que tu donnes devrait fonctionner sous openSUSE aussi de mémoire.

  7. #7
    Caméléon sympa Modérateur Avatar de chalu
    Inscrit
    mars 2019
    Lieu
    Anjou
    Distribution
    openSUSE Leap 15.1
    Environnement
    KDE celui de leap
    Messages
    285
    oui elle fonctionne, je l'ai testé en VM. Il me reste à tester en vrai avec un Live.
    J'ai pas téléchargé le bon fichier, le PC démarre pas dessus
    PC Portable ACER ASPIRE 5740G - Intel Core i5 430M 2.26GHz - ATI mobility Radeon HD 5470 - 4 GB de ram

  8. #8
    Grand caméléon Modérateur Avatar de jtro
    Inscrit
    dcembre 2009
    Lieu
    Pornichet,Bangkok,Almunecar
    Distribution
    leap 15.1 +Tumbleweed
    Environnement
    gnome3 + LXQT
    Messages
    3 073
    Bonjour,
    Le pilote catalyst fglrx n'est plus supporté par opensuse.
    Le pilote amdgpu-pro driver l'est pour les cartes à partir de HD 7XXX.
    Perso j'utilise le pilote libre radeon.
    https://en.opensuse.org/HCL:AMD_video_cards
    https://www.amd.com/en/support/kb/re...-lin-amdgpupro

  9. #9
    Caméléon bavard Modérateur Avatar de passionlinux
    Inscrit
    janvier 2013
    Lieu
    Val d'oise
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE
    Messages
    635
    Citation Envoyé par jtro Voir le message
    Bonjour,
    Le pilote catalyst fglrx n'est plus supporté par opensuse.
    Le pilote amdgpu-pro driver l'est pour les cartes à partir de HD 7XXX.
    Perso j'utilise le pilote libre radeon.
    https://en.opensuse.org/HCL:AMD_video_cards
    https://www.amd.com/en/support/kb/re...-lin-amdgpupro
    pareil en pilote libre

    J'ai pas téléchargé le bon fichier, le PC démarre pas dessus
    Tu cherches quoi?

  10. #10
    Caméléon sympa Modérateur Avatar de chalu
    Inscrit
    mars 2019
    Lieu
    Anjou
    Distribution
    openSUSE Leap 15.1
    Environnement
    KDE celui de leap
    Messages
    285
    oui c'est le pilote que j'utilise sur Debian 9 aussi et il est inclus dans le live avec le paquet kernel-firmware
    Code:
    sudo lscpi -nnk
    renvoie
    Code:
    02:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470] [1002:68e0]
            Subsystem: Acer Incorporated [ALI] Device [1025:033e]
            Kernel driver in use: radeon
            Kernel modules: radeon
    Je n'ai pas de souci sur Debian, ça semble fonctionner correctement avec le live USB d'openSUSE
    Tu peux nous en dire plus sur ton problème ?
    Comme dit passionlinux, c'est peut-être plus un problème matériel (PC/carte qui chauffe ? état de la carte mère ?) qu'un problème de firmware
    Dernière édition par chalu; 25/03/2019 à 18h57
    PC Portable ACER ASPIRE 5740G - Intel Core i5 430M 2.26GHz - ATI mobility Radeon HD 5470 - 4 GB de ram

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé