Affiche les résultats de 1 à 5 sur 5

Sujet : Boot sur un disque, plus sur l'autre

  1. #1
    Caméléon tenace Avatar de pierrotbj
    Inscrit
    dcembre 2008
    Lieu
    Bourgoin-Jallieu
    Distribution
    openSUSE Leap 15.0 (64 bits)
    Environnement
    KDE
    Messages
    1 305

    Boot sur un disque, plus sur l'autre

    Bonjour à tous,

    Sur mon PC remis à neuf l'an passé (carte mère HS) j'ai fait installer un SSD tout en gardant l'ancien disque dur.

    Sur le SSD, Leap 15.0 et 42.3 sur le disque dur.

    Par défaut, le PC démarre sur la Leap.
    Probléme nouveau : Ça veut pas, avec le message suivant :

    "You are in emergency mode, Donnez me mot de passe du super utilisateur, etc"


    IMG_20190518_195012.jpg

    Je tape mon mot de passe mais après, je sais pas trop comment procéder.

    Je précise que je peut démarrer sans problème sur le disque dur (42.3)
    Je vois le disque SSD mais je ne peut pas accéder au dossiers qui y sont.
    Un petit coup de Gparted, toujours depuis la 42.3 me confirme que tout est bien en place avec racine, home,etc.

    Merci d'avance pour votre aide
    "Ne pas subir . . . . ." Jean de Lattre de Tassigny

  2. #2
    Grand caméléon Avatar de moniroje
    Inscrit
    novembre 2005
    Lieu
    Massy-les flots
    Distribution
    Debian-Sid & Suse -Tumbleweed
    Environnement
    KDE
    Messages
    3 700
    Ce message, je me rappelle l'avoir eu quand une partition n'est pas reconnue; alors je vérifie l'UUID de chaque partition qu'il y a dans : /etc/fstab avec la commande blkid et si nécessaire, je corrige le fstab. Dans ton cas, ce serait le SSD à vérifier son UUID ?
    Sinon actualiser le grub ???
    http://www.monpcsurmesure.fr/Novembre 2014- Intel I7 4790-Kingston HyperX Fury 2x4 Go ramGygabyte GA-H97-HD3SSDNow V300 240 Go -KingstonSeagate Barracuda 500 SATA Go 6 Gb/sPure Power L8 500 wattsASUS DRW 24 F1s- Debian-Sid & Suse -Tumbleweed-Plasma5, xfce _ fibre Orange: 286Mbps down107Mbps up ping 1ms

  3. #3
    Caméléon tenace Avatar de pierrotbj
    Inscrit
    dcembre 2008
    Lieu
    Bourgoin-Jallieu
    Distribution
    openSUSE Leap 15.0 (64 bits)
    Environnement
    KDE
    Messages
    1 305
    Salut Moni,

    Je fais comment ?
    Je passe par Yast ?
    Je fais en ligne de commande ?
    Et sinon, comment actualiser le grub ?

    Là, je patauge complètement.
    "Ne pas subir . . . . ." Jean de Lattre de Tassigny

  4. #4
    Grand caméléon Avatar de moniroje
    Inscrit
    novembre 2005
    Lieu
    Massy-les flots
    Distribution
    Debian-Sid & Suse -Tumbleweed
    Environnement
    KDE
    Messages
    3 700
    Wé, tu passes par yast...
    mais aussi tu peux passer par la ligne de commande: sans doute en super u:
    d'abord tu tapes blkid -g qui met à jour.
    Puis blkid; tiens par exemple:
    Code:
    linux-t3sl:~ # blkid -g 
    linux-t3sl:~ # blkid
    /dev/sda1: LABEL="suse" UUID="e511bfb8-84da-40b5-8679-c9b0705fd030" TYPE="ext4" 
    /dev/sda3: UUID="845d3870-aa8f-4e89-89ac-35e71323b7b8" TYPE="ext4" 
    /dev/sda4: UUID="3647a264-84bd-4bc8-88d7-fb34dd624996" TYPE="ext4" 
    /dev/sda5: UUID="a4839232-1095-43a9-ac7d-353ea3aae18e" TYPE="swap" 
    /dev/sda6: LABEL="HomeSuse" UUID="fa4ca856-9b71-4b9f-a67e-95019408a317" TYPE="ext4" 
    /dev/sda7: UUID="ee7ea3e9-8f1f-441e-826a-fc5092c7ec44" TYPE="ext4"
    Tu te gardes ça sous la main et tu ouvres une autre console et là, tu ouvres avec gedit ou nano ou kwrite, ou... , en su le fichier /etc/fstab
    et tu vérifies dedans que chaque UUID soit conforme avec l'UUID correspondant que tu vois dans blkid. Si une différence, tu corriges le /etc/fstab
    Tout cela, faut faire gaffe: on me conseillait de faire copie de ce que j'allais toucher: par exemple fstab-old; mais bon, je n'ai jamais fait...

    Actualiser le grub?? alors là, c'est fastoche, tu as 2 commandes possibles, en su:
    update-bootloader --refresh
    ou bien:
    grub2-mkconfig -o /boot/grub2/grub.cfg
    C'est -o et non pas -0.
    Mais là aussi, yast peut le faire, je crois...
    http://www.monpcsurmesure.fr/Novembre 2014- Intel I7 4790-Kingston HyperX Fury 2x4 Go ramGygabyte GA-H97-HD3SSDNow V300 240 Go -KingstonSeagate Barracuda 500 SATA Go 6 Gb/sPure Power L8 500 wattsASUS DRW 24 F1s- Debian-Sid & Suse -Tumbleweed-Plasma5, xfce _ fibre Orange: 286Mbps down107Mbps up ping 1ms

  5. #5
    Caméléon tenace Avatar de pierrotbj
    Inscrit
    dcembre 2008
    Lieu
    Bourgoin-Jallieu
    Distribution
    openSUSE Leap 15.0 (64 bits)
    Environnement
    KDE
    Messages
    1 305
    Bon, voila le bilan des courses :

    J'ai essayé de faire selon ta méthode, mais j'ai vite arrêté, pas sûr de mon coup.

    J'ai partitionné le disque tout en conservant le /home d'origine puis fais une install toute neuve.

    J'ai donc sda2 avec la 15.0, sda3 le nouveau /home , sda5 l'ancien home et sda4 pour le swap :

    Screenshot_20190523_185728.png

    Mais je ne peu toujours pas accéder à ce foutu sda5 : Une erreur est survenue, l'opération a échoué, etc

    Screenshot_20190523_191550.png

    Voila, voila ou j'en suis, c'est à dire pas plus avancé
    "Ne pas subir . . . . ." Jean de Lattre de Tassigny

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé