Page 1 sur 2 12 DernièreDernière
Affiche les résultats de 1 à 10 sur 11

Sujet : kmymoney ne démarre pas

  1. #1
    Caméléon sympa
    Inscrit
    octobre 2006
    Lieu
    SAVERES (HAUTE GARONNE)
    Distribution
    openSUSELeap 15.0 (64bits)
    Environnement
    Gnome 3.x
    Messages
    353

    Question kmymoney ne démarre pas

    Bonjour,
    Je viens de passer à Leap 15.1. Pas de problème dans l'ensemble, sauf... Kmymoney. Au lancement, la première image s'affiche avec le logo K5,, puis plus rien. Comme s'y l'interface ne voulait pas se construire.J'ai installé successivement toutes les version existantes dans le centre de téléchargement d'OpenSuse, mais rien à faire.
    Je suis revenu à la version présente lors de la première installation. Lancé en console, le processus semble se dérouler correctement, sauf à la fin, où un message d'erreur apparaît : voici ce que ça donne :

    Cost center model created with items 0
    Payees model created with items 0
    [11625:11648:0529/013422.564220:ERROR:nss_util.cc(808)] After loading Root Certs, loaded==false: NSS error code: -8018
    [1:1:0100/000000.721704:ERROR:broker_posix.cc(41)] Invalid node channel message
    KCrash: Application 'kmymoney' crashing...
    KCrash: Attempting to start /usr/lib64/libexec/drkonqi from kdeinit
    sock_file=/run/user/1000/kdeinit5__1


    Comme j'ai toute ma compta sur Kmymoney depuis des années..... petit soucis, mais grands espoirs.
    La solution est toujours dans ce forum !
    Merci

  2. #2
    Caméléon sympa
    Inscrit
    octobre 2014
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE
    Messages
    322
    Je ne sais pas quelle est la solution,mais une quelle piste :
    Test un zypper inr, histoire de voire qu'il ne manque pas un paquets pour le forum.

  3. #3
    Caméléon bavard Modérateur Avatar de passionlinux
    Inscrit
    janvier 2013
    Lieu
    Val d'oise
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE
    Messages
    616
    Pas de solution mais peut etre ouvrir un bug sur le bugzilla de opensuse ou du moins regarder si c'est pas déjà fait et surtout temporairement ajouté le dépôt kde:extra avec une priorité inférieur aux autres dépots pour n'installer que kmymoney et regarder si ça change.

    Je pense que ton bug est celui ci:
    https://bugzilla.opensuse.org/show_bug.cgi?id=1136300

    Reste a attendre la solution.

    edit: je viens de confirmer le bug.
    Dernière édition par passionlinux; 29/05/2019 à 10h39

  4. #4
    Caméléon bavard Modérateur Avatar de passionlinux
    Inscrit
    janvier 2013
    Lieu
    Val d'oise
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE
    Messages
    616
    Bon déjà une réponse:

    The reporter should change back the state from "WAITINGFORINFO" in
    https://bugs.kde.org/show_bug.cgi?id=407902 if/when he provided the requested
    information so that it can proceed.

    I don't think this is a packaging issue, although it might be related to the
    used Qt version (the AppImage likely comes with its own Qt) or other factors.

    Does maybe renaming ~/.config/kmymoneyrc help?

    Pourrais tu rennomer le dossier ~/.config/kmymoneyrc et relancer kmymoney pour voir si au moins ça démarre?

  5. #5
    Caméléon sympa
    Inscrit
    octobre 2006
    Lieu
    SAVERES (HAUTE GARONNE)
    Distribution
    openSUSELeap 15.0 (64bits)
    Environnement
    Gnome 3.x
    Messages
    353
    Bonjour

    Je ne sais pas quelle est la solution,mais une quelle piste :
    Test un zypper inr, histoire de voire qu'il ne manque pas un paquets pour le forum.


    Je ne sais pas comment faire "zypper inr."
    Plein de bonne volonté.... mais un peu léger dans le domaine "ligne de commande".
    Merci

  6. #6
    Caméléon sympa
    Inscrit
    octobre 2006
    Lieu
    SAVERES (HAUTE GARONNE)
    Distribution
    openSUSELeap 15.0 (64bits)
    Environnement
    Gnome 3.x
    Messages
    353
    Bonjour,
    Dans mon répertoire personnel - fichiers cachés - j'ai renommé le dossier "kmymoney" en "kmymoneyrc". Dans le dossier "config" il y a aussi un fichier "txt" qui porte le même nom. Du coup il est écrasé.
    j'ai relancé Kmymoney. Il semble démarrer, il affiche la fenêtre des astuces et s'arrête là. j'ai répété l'opération plusieurs fois, avec le même résultat. Il se passe quelque-chose, mais ça n'aboutit pas.

    À suivre.

  7. #7
    Caméléon sympa
    Inscrit
    octobre 2006
    Lieu
    SAVERES (HAUTE GARONNE)
    Distribution
    openSUSELeap 15.0 (64bits)
    Environnement
    Gnome 3.x
    Messages
    353
    Bonjour,
    J'ai tenté quelque-chose : à partir de "openSUSE Download", j'ai installé la version de kmymoney pour Leap 15.0, à partir des dépôts communautaires. J'ai pris le premier de la liste. Cela à produit 52 modifications sur le système. J'ai eu quelques appréhensions quant au résultat !
    Au final, Kmymoney fonctionne dans sa version Leap 15.0. J'ai juste perdu "Dolphin" qui ne peut ouvrir aucun répertoire suite à une erreur "Impossible de créer le module d'entrée / sortie. klauncher a indiqué : Erreur lors du chargement de « /usr/lib64/qt5/plugins/kf5/kio/file.so ».
    Provisoirement, j'ai remplacé Dolphin par "Fichier" qui fonctionne normalement.
    On peut dire que pour l'instant, "une solution existe" si on a vraiment besoin d'utiliser Kmymoney, ce qui est mon cas. Les inconvénients sont minimes (tous mes autres logiciels photos, vidéo, etc... fonctionnent).
    Je surveillerai de temps en temps pour voir si le bug est résolu.
    Merci de votre aide et à bientôt.
    William

    PS : EST CE QUE JE MET QUE LE SUJET EST "RÉGLÉ" ???

  8. #8
    Caméléon bavard Modérateur Avatar de passionlinux
    Inscrit
    janvier 2013
    Lieu
    Val d'oise
    Distribution
    openSUSE Tumbleweed (64 bits)
    Environnement
    KDE
    Messages
    616
    Non car tu as cassé ton systeme, la 15.1 n'est pas une 15.0, tu viens de prendre un paquet de 15.0 qui t'as changé moulte paquet de 15.1 en 15.0...

    Le mieux est d'attendre que le bug soit résolu, as tu été voir sur bugzilla? Il avance, doucement mais il avance. https://bugzilla.opensuse.org/show_bug.cgi?id=1136300

  9. #9
    Caméléon sympa Modérateur Avatar de Bernado82
    Inscrit
    janvier 2016
    Lieu
    /home
    Distribution
    openSUSE Leap 15.1
    Environnement
    KDE Plasma 5.16
    Messages
    388
    Bonjour,

    J'ai essayé d'installer KMymoney sur ma Leap 15.0, passée en 15.1 récemment, mais tournant déjà sous KDE Plasma 5.15.90/Qt5.12 (et donc pas sous Plasma 5.12/Qt5.9) et bien, ça marche pas trop pour moi, car pour cela zypper propose une rétrogradation de centaines de paquets pour revenir à Qt5.9, mais ça j'ai pas envie...

    Comme quoi, chercher à être en avance sur les versions de Plasma et Qt fournies de base avec la Leap peut poser parfois problèmes avec certaines applications, notamment pour leurs dépendences (liées à des librairies plus anciennes), autant passer à Tumbleweed dans ce cas là?

    @William Massias

    Essayes Skrooge (à partir des dépôts officiels openSuse), c'est un concurrent de Kmymoney qui peut aussi importer/exporter les fichiers issus de KMM. Evidemment, comme pour Kmymoney, j'ai plus ou moins les mêmes difficultés à l'installer sur ma Leap 15.1, sauf à devoir (sans surprise) rétrograder les versions de Qt/KDE installées.

    EDIT: J'ai fait un test d'installation de KMymoney sans respect de ses dépendences et il fonctionne quand même, mais il sera bientôt désinstallé, justement pour les raisons que je viens d'évoquer (car sinon YaST est "fâché" à chaque fois).

    Conclusion, Kmymoney est susceptible de marcher, plus ou moins, sur Leap 15.1... Certains disent que lancer le programme avec la commande kmymoney -n permet de contourner provisoirement le problème.
    Dernière édition par Bernado82; 02/06/2019 à 23h33
    https://www.facebook.com/profile.php?id=100011319637977 (page orientée openSuse)
    https://open.spotify.com/user/bernad...eomqM38isNZRIj (playlist Spotify)

    Utilitaires pour Rockchip:
    https://www.mediafire.com/folder/2x8...Rockchip_Tools
    https://mega.co.nz/#F!wxJliCiT!fSTU4uzNwJ4h_ZGOYHcjcQ

    Les outils Rockchip sont parfois moches, voici RK Android Tool v2.3.9 et Driver Assistant v4.5 après mon petit coup de polish:
    https://www.mediafire.com/folder/5qs985buhb8g5/Rockchip

  10. #10
    Caméléon sympa
    Inscrit
    octobre 2006
    Lieu
    SAVERES (HAUTE GARONNE)
    Distribution
    openSUSELeap 15.0 (64bits)
    Environnement
    Gnome 3.x
    Messages
    353
    Bonjour Passionlinux
    Je me doutais bien d'un truc dans ce genre. En fait, dans ce que tu me dis, je suis repassé en 15.0 pour une bonne partie du système.
    Comme j'ai besoin de Kmymoney, le plus raisonnable serait de revenir sur 15.0, et d'attendre que le bug soit résolu tranquillement.
    Comme ça, j'ai un système cohérent qui a fait ses preuves.
    Je sis allé voir sur bugzillia,, je ne comprends pas tout, mais effectivement ça cherche et ça avance.

Tags pour ce sujet

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé