Bonjour,
Suite à mes essais avec mailnag, je me suis rendue compte que supprimer le paquet mailnag via YaST ne supprimait pas ses dépendances qui ne servent plus et ont été installées avec lui.
Je n'ai pas trouvé (ou pas réussi à comprendre) comment supprimer ces paquets inutiles.

Sinon en ligne de commande j'ai trouvé
Code:
sudo zypper remove --clean-deps mailnag
ça le fait râler car il n'y a pas de dépôt indiqué mais ça supprime bien tout
Code:
Avertissement : Pas de dépôt défini. Ne fonctionne qu'avec les résolvables installés. Rien ne peut être installé.
Lecture des paquets installés...
Résolution des dépendances des paquets...

Les 21 paquets suivants vont être SUPPRIMÉS :
  gnome-keyring gnome-keyring-lang gnome-keyring-pam libgck-modules-gnome-keyring libgnome-keyring0 libgnome-keyring-lang mailnag mailnag-lang
  python2-dbus-python python2-gobject python2-gobject-cairo python2-gobject-Gdk python2-pyxdg python-xml typelib-1_0-Atk-1_0
  typelib-1_0-GdkPixbuf-2_0 typelib-1_0-GnomeKeyring-1_0 typelib-1_0-Gst-1_0 typelib-1_0-Gtk-3_0 typelib-1_0-Notify-0_7 typelib-1_0-Pango-1_0

21 paquets à supprimer.
Après l'opération, 11,9 MiB d'espace disque sera libéré.
Continuer ? [o/n/v/...? affiche toutes les options] (o): 
( 1/21) Suppression de gnome-keyring-lang-3.28.2-lp151.1.2.noarch ......................................................................[fait]
( 2/21) Suppression de gnome-keyring-pam-3.28.2-lp151.1.2.x86_64 .......................................................................[fait]
( 3/21) Suppression de libgnome-keyring-lang-3.12.0-lp151.2.3.noarch ...................................................................[fait]
( 4/21) Suppression de mailnag-lang-1.2.1-lp151.2.2.noarch .............................................................................[fait]
( 5/21) Suppression de mailnag-1.2.1-lp151.2.2.noarch ..................................................................................[fait]
( 6/21) Suppression de typelib-1_0-Notify-0_7-0.7.7-lp151.3.2.x86_64 ...................................................................[fait]
( 7/21) Suppression de typelib-1_0-Gst-1_0-1.12.5-lp151.2.5.x86_64 .....................................................................[fait]
( 8/21) Suppression de typelib-1_0-GnomeKeyring-1_0-3.12.0-lp151.2.3.x86_64 ............................................................[fait]
( 9/21) Suppression de python2-pyxdg-0.25-lp151.2.1.noarch .............................................................................[fait]
(10/21) Suppression de python2-gobject-Gdk-3.26.1-lp151.2.3.x86_64 .....................................................................[fait]
(11/21) Suppression de python2-dbus-python-1.2.4-lp151.5.3.x86_64 ......................................................................[fait]
(12/21) Suppression de gnome-keyring-3.28.2-lp151.1.2.x86_64 ...........................................................................[fait]
(13/21) Suppression de libgnome-keyring0-3.12.0-lp151.2.3.x86_64 .......................................................................[fait]
(14/21) Suppression de typelib-1_0-Gtk-3_0-3.22.30-lp151.6.3.1.x86_64 ..................................................................[fait]
(15/21) Suppression de python2-gobject-cairo-3.26.1-lp151.2.3.x86_64 ...................................................................[fait]
(16/21) Suppression de python-xml-2.7.14-lp151.9.3.x86_64 ..............................................................................[fait]
(17/21) Suppression de libgck-modules-gnome-keyring-3.28.2-lp151.1.2.x86_64 ............................................................[fait]
(18/21) Suppression de typelib-1_0-Pango-1_0-1.40.14-lp151.3.3.x86_64 ..................................................................[fait]
(19/21) Suppression de typelib-1_0-GdkPixbuf-2_0-2.36.11-lp151.4.15.x86_64 .............................................................[fait]
(20/21) Suppression de typelib-1_0-Atk-1_0-2.26.1-lp151.3.4.x86_64 .....................................................................[fait]
(21/21) Suppression de python2-gobject-3.26.1-lp151.2.3.x86_64 .........................................................................[fait]
Certains programmes en cours d'exécution sont susceptibles d'utiliser des fichiers supprimés lors de la dernière mise à niveau. Peut-être souhaitez-vous vérifier et redémarrer certains d'entre eux. Exécutez 'zypper ps -s' pour obtenir une liste de ces programmes.
par contre si on a oublié cette option et fait un simple zypper remove paquet, y a-t-il moyen après coup de supprimer les dépendances devenus inutiles ?
l'option utilisée plus haut à besoin d'un nom de paquet donc ça ne marche pas.

Comme beaucoup je pense au début d'une installation, surtout d'un nouveau système, on fait quelques tests de logiciels et j'aimerais bien supprimer les paquets inutiles qui ont été installés en dépendance et qui sont restés malgré que le paquet testé soit supprimé.

Merci