+ Non Résolu
Page 1 sur 2 12 DernièreDernière
Affiche les résultats de 1 à 10 sur 20

Sujet : [Suse] Serveur SSH

  1. #1
    802.3x
    Guest

    Thumbs up

    Bonjour, je voudrais comment modifier le port écoute du serveur ssh..
    ou se situe les fichier pour apporter ses modification.


    Thks.

  2. #2
    Caméléon tenace
    Inscrit
    septembre 2004
    Lieu
    Assis sur la banquise (bzh)
    Messages
    1 910
    C'est /etc/ssh/sshd_config au début dans "default value"
    Port 22

  3. #3
    Il vaut éditer le fichier
    /etc/ssh/ssh_config

    tu as une instruction Port 22 avec un dièze pour le mettre en commentaire, décommentes la ligne et met le port que souhaites, je pense.

    Comme je n'ai jamais eu besoin de changer le port, je ne peux te garantir que ça marche, donc que cela fonctionne ou pas tu nous tiens au courant.
    Cordialement,

    Aldrik

    linux 2.6.22.9, gcc-4.1.2, glibc-2.5

  4. #4
    pdemong
    Guest
    Je suis pas sur, mais tu retrouves l'info dans /etc/services

    # Jon Postel <postel@isi.edu>
    ssh 22/tcp # SSH Remote Login Protocol
    ssh 22/udp # SSH Remote Login Protocol

    donc si tu veux modifier le port, modifie aussi dans ce fichier...

  5. #5
    Originally posted by pdemong@mardi 14 juin 2005 à 17:34
    Je suis pas sur, mais tu retrouves l'info dans /etc/services

    # Jon Postel <postel@isi.edu>
    ssh 22/tcp # SSH Remote Login Protocol
    ssh 22/udp # SSH Remote Login Protocol

    donc si tu veux modifier le port, modifie aussi dans ce fichier...
    <div align='right'><{POST_SNAPBACK}>
    [/quote]


    Que dis tu là !!!!!!???!!!????!!!!

    Surtout pas !!

    Ce fichier permet de nommer les ports et n'agis pas sur le service !!!

    Quand le système veut donner un nom plutôt qu'un numéro de port, il utilise ce fichier, il faut le considérer plus comme une base de nom, ce n'est pas un fichier de configuration.
    Cordialement,

    Aldrik

    linux 2.6.22.9, gcc-4.1.2, glibc-2.5

  6. #6
    802.3x
    Guest
    Effectivement sauf erreur de ma part j'ai apporté des modifications sur le fichier /etc/ssh/sshd_config
    port 22 ==> 342



    Cela dit il prennait bien en compte un changement car je ne pouvais plus acceder au poste via le port 22.

    En regardant de plus il y a bien un fichier ssh_config.
    /etc/ssh/ssh_config

    Mais tout les éléments sont en commentaire. ' # ' avec pour valeur # port 22

    je vais apporter des modifications. Et voir ce qui en retourne.. je vous tiens au courant..
    Thks..

  7. #7
    Originally posted by 802.3x@mercredi 15 juin 2005 à 11:08
    En regardant de plus il y a bien un fichier ssh_config.
    /etc/ssh/ssh_config

    Mais tout les éléments sont en commentaire. ' # ' avec pour valeur # port 22

    je vais apporter des modifications. Et voir ce qui en retourne.. je vous tiens au courant..
    Thks..
    <div align='right'><{POST_SNAPBACK}>
    [/quote]

    Je me suis trompé, ssh_config, configure le comportement du client ssh et sshd_config le serveur, donc dans ton cas c'est surtout sshd_config pour changer le port d'écoute, ssh_config va changer le par défaut utiliser pour se connecter à un serveur.

    Milles excuses, j'ai fait un copié collé du mauvais fichier sur le serveur.
    Cordialement,

    Aldrik

    linux 2.6.22.9, gcc-4.1.2, glibc-2.5

  8. #8
    802.3x
    Guest

    Thumbs down

    D'accord donc c'est bien au niveau du fichier sshd_conf que je dois apporter des modification.. port 22 le changer en port 342
    /etc/ssh/sshd_config

    Mais il ne prend pas en compte mes modifications. même apres un redemarrage de la machine..

    je n'arrive pas a cerner la cause.

  9. #9
    belaran
    Guest

    Thumbs down

    Originally posted by 802.3x@mercredi 15 juin 2005 à 10:57
    Mais il ne prend pas en compte mes modifications. même apres un redemarrage de la machine..

    je n'arrive pas a cerner la cause.
    J'ai essayé et g le même problème:

    Code:
    ARES:~ belaran$ ssh 192.168.10.103
    ssh: connect to host 192.168.10.103 port 22: Connection refused
    ARES:~ belaran$ ssh -p 243 192.168.10.103
    ssh: connect to host 192.168.10.103 port 243: Connection timeout
    Alors soit il manque une option coté client ou alors il manque quelquechose coté SuSe...
    Peut être au niveau du firewall ...

    Mais d'ailleurs ça doit être ça !

    802.3x tu peux essayer et me tenir au courant, car je n'ai pas accès à ma machine ( elle est chez moi et je suis au bureau ... )

  10. #10
    belaran
    Guest
    [Reglé]

    Ct bien le firewall... Dans la configuration de YaST, tu choisis configurer le firewall et dans la case expert tu ajoutes ton port en UDP et TCP.

    Je pense que SSH n'utilise que le TCP mais dans le doute... Je vais essayer de vérifier ( there is no need to let a port open for nothing...)


+ Non Résolu

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé