+ Résolu
Affiche les résultats de 1 à 9 sur 9

Sujet : [Réglé] chown ou fstab ?

  1. #1
    jrev
    Guest

    Post

    bonjour à tous,
    ayant réinstallé linux suse 9.1 je n'ai plus l'accès en écriture sur mes disquettes zip 100 qui sont la propriété de root

    je fais donc un changement de propriétaire vers le seul utilisateur jean par :

    linux:/home/jean # chown -R jean /media/zip
    chown: changing ownership of `/media/zip': Operation not permitted

    si je fais
    linux:/home/jean # chown -R jean /media/zip *.*
    j'ai la même réponse pourquoi ?

    pourquoi le superviseur ne peut-il donner la propriété de ses fichiers à l'utilisateur ?
    je ne comprends plus rien


    merci de vos réponses

  2. #2
    Grand caméléon arc-en-ciel Avatar de galagann
    Inscrit
    septembre 2004
    Lieu
    Lannoy, France
    Distribution
    openSUSE 13.2 (64 bits)
    Environnement
    KDE
    Messages
    14 119
    Salux,

    Malheuresement, je peux pas t'aider sur ce sujet, mais ce que je ne comprend pas dû tout c'est que ton lecteur Zip 100 n'est pas directement reconnue, alors que c'est un lecteur de média ultra-reconnue sous linux !!!

    C'est un ZIP internet ou externe ??? Que donne la commande "lspci" en mode root ?

    PS: Erreur de rubrique : Installation & Mise à jour du système d'exploitation SuSE", je pense qu'a cette étape du a déjà installer le système d'exploitation, c'est plutôt de la configuration système
    Ambassadeur et membre openSUSE - Région 59 Nord - France
    HP Probook 4350s sous openSUSE 13.2
    ==[GaLaGaNN's Blog]==


  3. #3
    douleme
    Guest
    pour ton problème ca doit être ton fstab qui n'a pas les bon paramètres peux tu nous afficher son contenu ?
    Il me semble que l'on ne peut pas modifier les droits d'un répertoire monté mais son contenu oui si c'est un système de fichier avec des droits (pas fat).
    Le plus simple est de mettre les bon doits dans le fstab.

  4. #4
    jrev
    Guest

    Post

    Ce qui est curieux c'est que j'ai remis l'ancien fstab qui marchait (après beaucoup de mise au point )
    Ce lecteur ZIP est parfaitement reconnu et je peux lire tous les fichiers qui sont sur la disquette
    le seul problème je ne peux ni modifier ni supprimer ces fichiers/dossiers

    la ligne de fstab est la suivante :

    /dev/hdd4 /media/zip auto noauto,user,iocharset=iso8859-15,codepage=850,umask=0 0 0

    et si je fais :

    jean@linux:~> ls -l /media/zip j'obtiens ->
    total 29216
    -rwxrwxrwx 1 root root 117772 2004-10-29 19:08 dvd+rw-tools-5.20.4.10.8-0.pm.1 .i586.rpm
    -rwxrwxrwx 1 root root 8483022 2004-10-07 10:53 firefox-1.0PR-i686-linux-gtk2+x ft-installer.tar.gz

    je peux ajouter un fichier sur la disquette zip mais ne peux le resortir
    si ce fichier appartient à l'utilisateur le fait de le copier sur la disquette il devient root, root automatiquement et ne peux plus être modifié que par root
    c'est donc bien un problème de propriété

  5. #5
    Pourtant tu as tous les droits sur ces fichiers...
    Lulu's Wiki
    marié depuis le 9 juillet ;-P

  6. #6
    jrev
    Guest

    Post

    la ligne "fstab" en question :
    /dev/hdd4 /media/zip auto noauto,user,iocharset=iso8859-15,codepage=850,umask=0 00

    les dossiers/fichiers ont tous les droits :
    jean@linux:~> ls -l /media/zip
    total 29216
    -rwxrwxrwx 1 root root 117772 2004-10-29 19:08 dvd+rw-tools-5.20.4.10.8-0.pm.1 .i586.rpm

    le problème c'est que si je glisse un fichier appartenant à user (jean) dans cette disquette zip il change de propriétaire et devient root,root comme tu peux voir ci-dessus

    et si je tente de glisser ce fichier sur le bureau j'ai le menu copier ou lier mais pas transférer (copy or link but not move, j'ai installé la suse en anglais )

    curieux non ?

    il doit y avoir une modif à faire quelque part mais où ?
    puisque j'ai remis le même fichier fstab avec lequel le zip fonctionnait OK avant ma réinstallation de suse 9.1

    merci pour votre réponse je pense avoir tout dit

  7. #7
    jacqueline
    Guest
    Essayes de le monter dans fstab avec l' option : uid= afin de fixer le propriétaire à ton numéro de user, lors du montage.

    Mais c'est curieux en effet puisque dans ton cas la troisième classe "users" (cad tout le monde) a les droits rwx

    C'est ce que je fais pour les partitions de données supplémentaires réservées à quelques utilisateurs, avec le trio uid, gid et umask, sinon on tombe sur le même problème dès que c'est root le propriétaire d'une partition.

    Après il faut regarder l'option : appliquer les droits à tous les dossiers.

    ( voir au bas de cette page) fstab uid gid

    Jacqueline

  8. #8
    Nouveau caméléon
    Inscrit
    septembre 2004
    Lieu
    Templeuve
    Messages
    209
    Salut,

    Comme beaucoup te l'ont dit, essayes avec le uid=
    Par défault sous SuSE 9.1, si tu es le premier utilisateur (apreès root bien sur) ton uid est de 1000

    Voilà ce que j'aurais mis dans ton fstab :
    /dev/hdd4 /media/zip auto noauto,users,iocharset=iso8859-15,codepage=850,uid=1000

    Je me demande si le iocharset et le codepage ne font pas double emploi. ^^

    @+,
    Guile.

  9. #9
    jrev
    Guest

    Post

    merci à tous,
    pour mon zip la solution est là dans la ligne suivante de fstab:

    /dev/hdd4 /media/zip auto auto,rw,user,uid=1000,umask=000 00

    il ne faut pas oublier comment sont délimités les colonnes et les paramètres dans le fichier fstab (respectivement espace et virgule ) et quelles sont les fonctions de ces paramètres

    Et puisque KDE 3.2.1 n'a pas prévu le montage/démontage par un clic de l'utilisateur sur l'icone du zip il est peut-être possible de faire deux scripts pour monter ou démonter le zip d'un seul clic (ou de modifier le menu du clic droit ?)
    pourriez-vous m'indiquer comment ?

+ Résolu

Règles des messages

  • Vous ne pouvez pas créer de sujets
  • Vous ne pouvez pas répondre aux sujets
  • Vous ne pouvez pas importer de fichiers joints
  • Vous ne pouvez pas modifier vos messages
  •  
  • Les BB codes sont Activés
  • Les Smileys sont Activés
  • Le BB code [IMG] est Activé
  • Le code [VIDEO] est Activé
  • Le code HTML est Désactivé