Aller au contenu principal
Sujet: Message lors de la mise à jour tumbleweed (Lu 1973 fois) sujet précédent - sujet suivant

Message lors de la mise à jour tumbleweed

Bonjour
Je veux faire la mise à jour de Tumbleweed KDE et j'ai ce message.
Récupération des métadonnées du dépôt 'packman' .........................................................[fait]
Construction du cache du dépôt 'packman' ................................................................[fait]
Chargement des données du dépôt...
Lecture des paquets installés...
Avertissement : Vous êtes sur le point d'exécuter une mise à niveau de distribution avec tous les dépôts activés. Assurez-vous que ces dépôts sont compatibles avant de continuer. Reportez-vous à 'man zypper' pour obtenir plus d'informations sur cette commande.
Calcul de la mise à niveau de la distribution...

Problème : problème avec l'élément libswresample4-5.1.2-16.2.x86_64 installé
 Solution 1 : Les actions suivantes seront exécutées :
  conserver l'élément libswresample4-5.1.2-16.2.x86_64 obsolète
  conserver l'élément libavutil57-5.1.2-16.2.x86_64 obsolète
 Solution 2 : désinstallation de libswresample4-5.1.2-16.2.x86_64

Choisir une des solutions ci-dessus en tapant son numéro ou bien annuler en tapant 'a' [1/2/a/d/?] (a): 2
Résolution des dépendances...
Calcul de la mise à niveau de la distribution...

Les 16 paquets suivants vont être remis à une version inférieure :
  libavcodec59 libavfilter8 libavformat59 libavutil57 libgbm1 libpostproc56 libswscale6 libvulkan_intel Mesa
  Mesa-dri Mesa-gallium Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 Mesa-libva Mesa-vulkan-device-select

Le NOUVEAU paquet suivant va être installé :
  libswresample4_ff5

Le paquet suivant va être SUPPRIMÉ :
  libswresample4

16 paquets à rétrograder, 1 nouveau, 1 à supprimer.
Taille de téléchargement totale : 36,7 MiB. Déjà en cache : 0 B. Aucun espace supplémentaire ne sera utilisé ou
libéré après l'opération.
Continuer ? [o/n/v/...? affiche toutes les options] (o):
J'ai choisi l'option 2 pour voir ce que àa allait faire mais sans l'exécuter. J'ai tout annulé.
Question, pourquoi ce message et que dois-je faire ?
Merci

Re : Message lors de la mise à jour tumbleweed

Répondre #1
@C2G9 : Bonjour,

Même chose chez moi. Ces paquets sont en relation avec Packman. Solution 1 ou solution 2, c'est coton dans les deux cas si j'en crois cette discussion sur Reddit où les deux solutions ont été un peu éprouvées :

https://www.reddit.com/r/openSUSE/comments/11sl1a7/dependencies_problem_with_the_lastest_dup/

Discussion à suivre mais en ce qui me concerne, dans l'immédiat,  j'attends.

Re : Message lors de la mise à jour tumbleweed

Répondre #2
OK je vais attendre aussi par prudence !
Bonne journée

Re : Message lors de la mise à jour tumbleweed

Répondre #3
@C2G9 :

Sur le forum officiel (branche espagnole) : https://forums.opensuse.org/t/error-al-actualizar-opensuse-tw/164976

VariableStar dit (traduction) :

Citer
Il s'agit d'un problème typique souvent causé par un paquetage qui n'a pas été compilé correctement. La meilleure solution est d'attendre, peut-être quelques heures, peut-être quelques jours, mais cela résout toujours le problème.

Discussion à suivre également.

Bonne soirée

Re : Message lors de la mise à jour tumbleweed

Répondre #4
Bonjour :)
C'est aussi typique de l'utilisation de packman avec Tumbleweed.
C'est un peu comme avec les dépôts Nvidia, ça ne va pas toujours avec le bon rythme (par rapport à TW) dans les mises à jour.
libswresample4_ff5 est un paquet lié à ffmpeg.

Et tu as sans doute passé ce type de paquet sur packman. J'ai opté pour ma part, depuis qu'il fonctionne pour le dépôt plus officiel pour les codecs.
J'utilise Firefox officiel et ça semble fonctionner, il lit bien les vidéos des replays ou youtube.
Je n'ai pas trop testé avec vlc, mais ça doit fonctionner je pense.
Pour d'autres logiciels, comme obs-studio, j'utilise la version flatpak.
Depuis que c'est comme ça. Je n'ai plus eu ce type de souci.  :)


Re : Message lors de la mise à jour tumbleweed

Répondre #5
Oui ça vient de packman. Si je supprime le dépôt packman, qu'est-ce que je dois entrer dans le terminal pour repasser avec les dépôts "officiels" ?
Pour packman, j'avais fait
sudo zypper dup --from packman --allow-vendor-change
mais là ?

Reste à voir aussi pour vlc si il peux lire les vidéos ...

Re : Message lors de la mise à jour tumbleweed

Répondre #6
Bonsoir,

Aujourd'hui la mise à jour passe sans poser de question. Elle avertit seulement que 16 paquets (de Packman) vont être rétrogradés :

Les 16 paquets suivants vont être remis à une version inférieure :
  libavcodec59 libavfilter8 libavformat59 libavutil57 libgbm1 libpostproc56
  libswscale6 libvulkan_intel Mesa Mesa-dri Mesa-gallium Mesa-libEGL1 Mesa-libGL1
  Mesa-libglapi0 Mesa-libva Mesa-vulkan-device-select

Et libswresample4 est supprimé (remplacé par libswresample4_ff5 nouvellement installé, je suppose).

Pour moi c'est bon je pense.

Re : Message lors de la mise à jour tumbleweed

Répondre #7
Bonjour
Oui pareil pour moi. C'est quand même dérangeant ces problèmes de dépôt.

Re : Message lors de la mise à jour tumbleweed

Répondre #8
C'est quand même dérangeant ces problèmes de dépôt.

Bonjour,

Pas trop je trouve car cela se résout assez vite en général. Juste un peu déstabilisant quand comme moi on ne maîtrise pas trop ces histoires de codecs. Il reste la solution de Chalu pour se passer de Packman en activant ce nouveau dépôt. Avec quelles conséquences par ailleurs? Je n'arrive pas à mesurer dans l'immédiat.

Re : Message lors de la mise à jour tumbleweed

Répondre #9
Une conséquence pour ne pas utiliser packman, c'est d'utiliser flatpak par exemple si tu as besoin d'un logiciel qui est habituellement fourni par packman. Tout dépend de ton usage.
Pour vlc, il lit bien chez moi le codec h264.

Re : Message lors de la mise à jour tumbleweed

Répondre #10
Bonjour
Des nouvelles : installation ce jour de thumbleweed KDE. Je n'utilise pas le dépôt packman mais seulement les dépôts officiels
zypper repos
Les priorités des dépôts sont sans effet. Tous les dépôts activés partagent la même priorité.

# | Alias                            | Name                                   | Enab-> | GPG Check        | Refresh
--+----------------------------------+----------------------------------------+--------+------------------+-----------
1 | download.opensuse.org-non-oss    | Dépôt principal (NON-OSS)              | Oui    | (r ) Oui         | Oui
2 | download.opensuse.org-oss        | Dépôt principal (OSS)                  | Oui    | (r ) Oui         | Oui
3 | download.opensuse.org-tumbleweed | Dépôt principal de mise à jour         | Oui    | (r ) Oui         | Oui
4 | openSUSE-20230221-0              | openSUSE-20230221-0                    | Non    | ----             | ----
5 | repo-debug                       | openSUSE-Tumbleweed-Debug              | Non    | ----             | ----
6 | repo-openh264                    | Open H.264 Codec (openSUSE Tumbleweed) | Oui    | (r ) Oui         | Oui
7 | repo-source                      | openSUSE-Tumbleweed-Source             | Non    | ----             | ----
Apparemment Firefox lit bien les vidéos des replays ou de youtube ainsi que VLC les mp3 et ogg. Par contre, pour les vidéos que j'ai sur mon PC, ça ne fonctionne pas.

Je désinstalle VLC et installe celui de flathub. Je peux lire toutes mes vidéos.

Pas encore tout à fait au point les codecs h264 on dirait !
J'ai installé gstreamer-1.20-plugin-openh264 comme recommandé ici https://news.opensuse.org/2023/01/24/opensuse-simplifies-codec-install/
zypper info gstreamer-1.20-plugin-openh264
Chargement des données du dépôt...
Lecture des paquets installés...


Informations sur paquet gstreamer-1.20-plugin-openh264 :
--------------------------------------------------------
Dépôt                     : Open H.264 Codec (openSUSE Tumbleweed)
Nom                       : gstreamer-1.20-plugin-openh264
Version                   : 1.20.3-1.suse1599.1
Architecture              : x86_64
Fabricant                 : obs://build.opensuse.org/openSUSE:Factory
Taille une fois installé  : 77,3 KiB
Installé                  : Oui
État                      : à jour
Paquet source             : gstreamer-1.20-plugin-openh264-1.20.3-1.suse1599.1.src
URL en amont              : https://gstreamer.freedesktop.org
Résumé                    : Gstreamer openh264 plugin
Pour les vignettes des vidéos dans dolphin, ben c'est pas ça non plus !

Re : Message lors de la mise à jour tumbleweed

Répondre #11
J'utilise le dépôt Packman depuis qu'il existe et je n'ai jamais eu de souci. Par contre avec Leap ou Tumbleweed, je passe toujours par Yast et en cas de conflits de paquets je choisis toujours de conserver le paquet soi-disant obsolète  ce qui évite des désinstallation ou des rétrogradations et cela fait plusieurs années que je procède ainsi. Ce n'est qu'une manière de faire et chacun procède comme il l'entend.