Aller au contenu principal
Sujet: openSUSE et PHP 8 (Lu 453 fois) sujet précédent - sujet suivant

Re : openSUSE et PHP 8

Répondre #15
Dans le détail, tu le fais comment ce changement de PHP ?


à plus,
oh!rocks

Re : openSUSE et PHP 8

Répondre #16
J'ai essayé plusieurs trucs.

Avec Yast soit en commençant par installer php7 puis mis a jour vers php8 même résultat apache ne veut pas démarrer.

Sans Yast mais avec la commande Apache a2enmod ca fonctionne pour php7 et pour php8. Apache démarre mais les scripts ne sont pas executés!!!

A noté j'ai essayé sur une Mageia 8RC et aucun problème pour le faire fonctionner.
Je me demande si les paquets php8 sont pas tous moisis.........


Re : openSUSE et PHP 8

Répondre #17
Est-ce qu'Apache se lance avec une simple page html ?

Sur certains sites, il y a conflit entre d'anciennes conf php7 non nettoyées et les nouvelles conf php8.

Si tu te sens de repartir de zéro (à ce stade de non fonctionnement, je suppose que tu n'as pas encore fait beaucoup de personnalisation) :

1. désinstalle tout apache et php avec Yast (ne pas oublier de cocher -> 0ptions -> Nettoyer lors de la suppression)
2. installe juste Apache
3. crée un hôte virtuel (n'oublie pas de renseigner le fichier /etc/hosts) et teste un fichier html
4. installe php8 sans les modules : vérifie sur un fichier php
5. si ça tourne, installe les modules un par un et vérifie à chaque fois.

Je sais, c'est lourd. Mais ça permettra peut-être d'y voir plus clair.

Bon courage. :)


à plus,
oh!rocks

Re : openSUSE et PHP 8

Répondre #18
Déjà fait mais sans succès !!

Ca fonctionne pour le html mais pas le php au mieux !!

Re : openSUSE et PHP 8

Répondre #19
hello Pascal

question simple, pour confirmer que ton message d'erreur initial "classique" porte bien sur "Require local" et que ce n'est pas un effet de bord, car "Require" est un truc bateau de chez bateau : https://httpd.apache.org/docs/2.4/howto/access.html

d'après la doc, ce type de directives est portée par deux modules : "Access control can be done by several different modules. The most important of these are mod_authz_core and mod_authz_host. "

et si ces modules ne sont pas chargés par httpd.conf avant d'en utiliser les directives, alors la partie générique de apache-core va juste dire qu'il n'a jamais entendu parler de ces mots clés bizarres et donc il va s'arrêter direct

peux-tu vérifier que tu as bien des lignes 'LoadModule' correspondantes (et non commentées) si tu suis le jeu des includes dans /etc/apache2/httpd.conf ?  (chez moi ils sont bien présents et non commentés dans /etc/apache2/loadmodule.conf, qui est chargé au début du fichier httpd.conf)

il y a peut-être un effet indirect avec ton paquet php-8, car "le script d'install de php-8 bricole les fichiers de conf apache2", et chez le mainteneur ça marche, mais comme il n'a pas le même conf que toi, alors pas de bol sur ton host ça se passe mal ?

si les modules sont chargés (et donc que les keywords sont connus par apache-core), alors ton erreur est un effet de bord, et la vraie erreur est ailleurs...

je te conseille en premier de lancer 'ldd' sur tous les modules mod_*.so, pour voir si il n'y en aurait pas un à qui il manquerait des dépendances au link, et donc ça serait une erreur indirecte remontée par apache-core en mode panique (en utilisant la directive X du module Y, ca a merdé et donc j'affiche une erreur Z). toujours la même idée : le host de build a tiré une dépendance sur une version de lib plus récente que sur ta machine, mais comme le mainteneur a oublié d'en tenir compte dans les dépendances du paquet, ... alors la mise à jour de la dépendance sur ton host n'a pas été vue quand tu as installé ce paquet php-8 (en clair ton install ne peut pas marcher car les binaires sont "dans le futur" par rapport à ta config)

si la chasse aux binaires ne suffit pas, je te conseille de mettre le httpd.conf original de côté et d'en construire un à toi, linéaire par copier/coller à partir des includes, qui commence par charger tous les modules en bloc, puis qui contient les directives --> quand l'erreur apparaîtra, le numéro de ligne devrait être plus indicatif et te donner la vraie raison du pb

et sinon je n'ai pas d'autre idée....

eric

Re : openSUSE et PHP 8

Répondre #20
Merci pour la réponse mais franchement je vais pas me refaire toute la configuration d'Apache !!!

As tu réussi a faire fonctionner php 8 sur openSUSE ??