Aller au contenu principal
Sujet: Activé le bluetooth au démarrage (Lu 41 fois) sujet précédent - sujet suivant

Activé le bluetooth au démarrage

Bonjour,
j'essai de faire en sorte que le bluetooth soit activé au démarrage et que ma souris y soit connecté...sans succès. J'ai suivi ces infos :
Citer
Problems with all BLE devices on kernel 5.9+
Starting with v5.9, the kernel Bluetooth stack tries to use link-layer privacy on BLE connections. If the device works after pairing but does not survive a reboot or suspend, it is probably because of this.
To workaround [2] this issue, open /var/lib/bluetooth/<adapter mac>/<device mac>/info, remove the following lines, and restart bluetooth.service:
[IdentityResolvingKey]
Key=...

puis ça :
Citer
The solution that worked for me (Tumbleweed):
1 - Open the file /etc/systemd/system/bluetooth.target.wants/bluetooth.service
2 – Seach for the “WantedBy=bluetooth.target” and add “default.target”:
[Install]
WantedBy=bluetooth.target default.target
Now the bluetooth will be required in the boot.
3 – Install the bluez-auto-enable-devices package:
zypper in bluez-auto-enable-devices
This will create the /etc/bluetooth/main.conf
Open it and make sure “AutoEnable” is true: “AutoEnable=true”
4 -Reboot

j'ai bien fait le :
systemctl enable bluetooth.service

Dans Yast ça semble ok (cf image)

Donc là je vois pas pourquoi j'ai pas le bluetooth au démarrage...

Je suis sous KDE 5.22

Merci pour votre aide et bonne journée