Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: MyPaint ne se lance pas (Lu 429 fois) sujet précédent - sujet suivant

MyPaint ne se lance pas

Bonjour,

Un petit souci avec MyPaint (version installée : 1.1.0-9.1 sous Tumbleweed). Ce dernier ne se lance pas. Si vous avez une idée...

En lançant MyPaint en mode console, j'ai ceci :
mypaint

We are not correctly installed or compiled!
script: "/usr/bin/mypaint"
deduced prefix: "/usr"
lib_shared: "/usr/share/mypaint/"
lib_compiled: "/usr/lib64/mypaint/"

Traceback (most recent call last):
  File "/usr/bin/mypaint", line 170, in <module>
    datapath, extradata, confpath, localepath, localepath_brushlib = get_paths()
  File "/usr/bin/mypaint", line 111, in get_paths
    from lib import mypaintlib
  File "/usr/share/mypaint/lib/mypaintlib.py", line 13, in <module>
    from . import _mypaintlib
ImportError: cannot import name _mypaintlib

 

Re : MyPaint ne se lance pas

Répondre #1
Il doit y avoir un petit souci. Je viens de l'installer, et j'ai le même message.

Re : MyPaint ne se lance pas

Répondre #2
Bonjour,

Pas de problème sur Manjaro, et sur Leap15.1 j'ai des problèmes de dépendances avec python ("no module pygtk found", un truc du genre, malgré installation des dépendances). Sur TW, étrange message quand on installe depuis les paquets communautaires:


En attendant, utilise la .AppImage proposée sur github. Tu télécharges le fichier, tu le rends executable, tu le mets dans un dossier Mypaint dans ton dossier personnel puis en console:
cd /home/ton-utilisateur/ton-dossier-Mypaint
./MyPaint---20190322.AppImage

Re : MyPaint ne se lance pas

Répondre #3
Bonjour,
Merci Gleizoux, ta soluce fonctionne nickel !
Petite frayeur au départ, car il m'a été indiqué que l'appli ne pouvait s'exécuter pour des raisons de sécurité mais c'était une grossière erreur de ma part.
Je passe en résolu.

Re : MyPaint ne se lance pas

Répondre #4
Je t'en prie !

Je passe en résolu.

Oui... et non. Car s'il y a des bugs sur le rpm présent dans les dépôts, et -j'imagine- des dépendances non résolues et non citées par Yast il faudra peut-être corriger.

Je n'ai pas plus d'infos, y a-t-il des bugs déjà répertoriés sur bugzilla vis-à-vis de ce logiciel ?

Le passage par AppImage est un plan B en attendant que les choses reviennent en ordre ;)

Re : MyPaint ne se lance pas

Répondre #5
Bonjour,

Ok ok pour le résolu pas (vraiment) résolu ! Mais merci encore pour le plan B !
Rien vu sur bugzilla ou alors j'ai mal cherché.

J'ai trouvé çà sur le forum anglophone. Un peu vieux (2014) mais çà ressemble fortement à mon problème si j'ai tout pigé.

J'ai testé avec python2-numpy et python3-numpy. Même punition. Je garde le plan B.