Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: MàJ j'hésite  (Lu 187 fois) sujet précédent - sujet suivant

MàJ j'hésite

Bonjour à toutes et tous
J'ai ce matin une centaine de MàJ , mais j'ai un message d'avertissement sur l'une d'elle . Cela concerne Mesa qui est un pilote Nvidia , mais dessus , j'ai déjà eu une alerte disant que c'était un pilote  en cour de développement et donc pas trés sûr  , et qu'il risque de poser des problémes
Seulement , ce matin il me demande de ddéverrouiller les MàJ que j'avais bloquées
linux-bhnz:/home/jenrem # zypper dup
Chargement des données du dépôt...
Lecture des paquets installés...
Avertissement : Vous êtes sur le point d'exécuter une mise à niveau de distribution avec tous les dépôts activés. Assurez-vous que ces dépôts sont compatibles avant de continuer. Reportez-vous à 'man zypper' pour obtenir plus d'informations sur cette commande.
Calcul de la mise à niveau de la distribution...

Problème : Mesa-19.3.2-236.2.x86_64 requiert Mesa-dri = 19.3.2, mais cette dépendance ne peut pas être fournie
  fournisseurs non installables : Mesa-dri-19.3.2-236.2.i586[download.opensuse.org-oss]
                  Mesa-dri-19.3.2-236.2.x86_64[download.opensuse.org-oss]
 Solution 1 : Les actions suivantes seront exécutées :
  enlever le verrou pour permettre l'installation de Mesa-dri-19.3.2-236.2.i586[download.opensuse.org-oss]
  installer Mesa-dri-19.3.2-236.2.i586 en dépit de l'architecture inférieure
  enlever le verrou pour permettre la suppression de Mesa-dri-19.3.1-235.1.x86_64
 Solution 2 : Les actions suivantes seront exécutées :
  enlever le verrou pour permettre l'installation de Mesa-dri-19.3.2-236.2.x86_64[download.opensuse.org-oss]
  enlever le verrou pour permettre la suppression de Mesa-dri-19.3.1-235.1.x86_64
 Solution 3 : Les actions suivantes seront exécutées :
  désinstallation de Mesa-19.3.2-236.1.x86_64
  désinstallation de patterns-kde-kde_plasma-20181130-3.2.noarch
  désinstallation de kcm_tablet-lang-3.2.0-1.2.noarch
  désinstallation de patterns-kde-kde-20181130-3.2.noarch
 Solution 4 : conserver Mesa-19.3.2-236.1.x86_64 obsolète
 Solution 5 : casser Mesa-19.3.2-236.2.x86_64 en ignorant certaines de ses dépendances

Choisir une des solutions ci-dessus en tapant son numéro ou bien annuler en tapant 'a' [1/2/3/4/5/a/d/?] (a):


Est ce que cette MàJ fait de ce pilote  un pilote totalement développé et donc sûr , qui remplacerait un pilote de toute façon déjà installé dans une version plus ancienne
Je dois dire que la solution 3 me fait un peu peur , je n'ai pas envie de toucher à KDE
Est ce que l'on peut trouver une doc sur ce pilote , pour en savoir un peu plus
Merci

Re : MàJ j'hésite

Répondre #1
@jenrem‍ 


Perso, je prends la solution : 2

* je reste dans une architecture de base
* le dépôt oss est plus que bien connu... 
* et ça supprime l'ancienne version pour une nouvelle... 
* les dépôts oss, ne te donnent pas de version dev, c'est plutôt le cas de la branche "Expérimental" -il me semble- 

Re : MàJ j'hésite

Répondre #2
Bonsoir Yoman
 Merci , je vais prendre cette option . J'hésitais entre la 2 et la 4 qui me faisait rester avec une ancienne version
Je vais voir si j'ai encore le message de mise en garde
Bonne soirée

Re : MàJ j'hésite

Répondre #3
J'ai fait les MàJ ce matin après avoir déverrouillé  les paquets concernés , cela c'est très bien passé
Merci
Je passe en [résolu)