Aller au contenu principal
Sujet: Version PHP pour Leap 15.2 (Lu 91 fois) sujet précédent - sujet suivant

Version PHP pour Leap 15.2

 Bonjour

Je poste dans cette rubrique car Leap15.2 n’est pas sortie mais n’hésitez pas, bien sûr, à déplacer mon post dans une autre rubrique au besoin.

En regardant sur software.opensuse.org je vois que c’est une version php7.3.x qui est proposée pour Leap15.2
Est-ce que la décision est prise de rester sur cette branche ou est-ce qu’il est encore possible que php7.4 soit choisi ?

Merci pour vos lumières.

A+

Re : Version PHP pour Leap 15.2

Répondre #1
Salut,
À ce stade il n'y a guère de chance que ça change, ça restera en 7.3. De toute façon de nombreuses applications, embarquées dans Leap 15.2 ou pas, ne pas compatibles avec 7.4.


Re : Version PHP pour Leap 15.2

Répondre #3
Merci pour vos retours.

J’utilise aujourd’hui php7.3 et ses extensions via des dépôts de développement / expérimentaux avec Leap 15.1
Le souci, au-delà de mise à jour très fréquentes de PHP qui me change la permission d’un répertoire, j’ai un problèmede synchronisation de mise à jour du dépôt des extensions avec le dépôt PHP. Du coup, j’ai des extensions qui ne deviennent plus compatibles.

Bref, je pense rester à l’avenir sur le dépôt officiel. Apparemment, certains utilisateurs de Nextcloud  ont noté un gain en performance avec PHP 7.4. Mais 7.3 est quand même suffisamment récent pour mes besoins, je pense.

A suivre...

A+