Aller au contenu principal
Sujet: APC Back-UPS ES550 ne bascule plus sur batterie (Lu 101 fois) sujet précédent - sujet suivant

APC Back-UPS ES550 ne bascule plus sur batterie

Bonjour à toutes et tous.

Ce n'est probablement pas un problème lié à openSUSE mais il y a probablement des personnes avec des compétences qui me manquent pour dépanner tout seul mon souci.

J'ai un petit onduleur/batterie de secours (APC Back-UPS ES550) sur lequel est branché mon serveur Nextcloud sous Leap.
Le but est qu'un coupure de courant de quelques minutes n'arrêtent pas mon serveur et, si cela dure plus longtemps, de lui laisser le temps de s'arrêter proprement. J'ai installé pour cela le paquet APCUPSD.
En cas de coupure de courant, comme la batterie de secours est connectée par un câble USB au serveur, le service apcupsd détecte la coupure de courant, fait m'envoyer un email (la box est aussi connectée sur la batterie) et déclenche l'arrêt propre du serveur si la coupure dure plus que quelques minutes.
Cela marchait impeccable depuis Janvier 2019 (date de l'achat de l'appareil).

Avant-hier, on a fait disjoncter tout l'appartement... Pas de dégâts heureusement. Par contre, je m'aperçois que le serveur s'est arrêté brutalement... Je fais des tests hier et, effectivement, en cas de coupure d'alimentation, la batterie de secours fait bien ses 4 bips pour dire qu'elle passe sur batterie mais les prises qui doivent fonctionner sur batterie ne délivrent aucun courant !  :o
Pourtant, un contrôle de la charge des batteries avec APCUPSD montre qu'elles se sont un peu déchargées !!  :o

J'ai essayé, sans succès, de déconnecter et reconnecter la batterie et de tester qu'avec la box branchée sur le rack de secours.

Pourtant, le voyant de fonctionnement et de santé de la batterie est toujours vert.

Quand j'exécute sudo apcaccess status , j'obtiens qu'apparemment tout fonctionne et que la batterie est en bon état (enfin, je crois) :
APC      : 001,034,0838
DATE     : 2020-04-03 10:27:24 +0200 
HOSTNAME : linux-q3fi
VERSION  : 3.14.14 (31 May 2016) suse
UPSNAME  : ES550G
CABLE    : USB Cable
DRIVER   : USB UPS Driver
UPSMODE  : Stand Alone
STARTTIME: 2020-04-02 19:15:10 +0200 
MODEL    : Back-UPS ES 550G
STATUS   : ONLINE
LINEV    : 234.0 Volts
LOADPCT  : 0.0 Percent
BCHARGE  : 100.0 Percent
TIMELEFT : 65.8 Minutes
MBATTCHG : 5 Percent
MINTIMEL : 3 Minutes
MAXTIME  : 0 Seconds
SENSE    : Medium
LOTRANS  : 180.0 Volts
HITRANS  : 266.0 Volts
ALARMDEL : 30 Seconds
BATTV    : 13.6 Volts
LASTXFER : Unacceptable line voltage changes
NUMXFERS : 0
TONBATT  : 0 Seconds
CUMONBATT: 0 Seconds
XOFFBATT : N/A
STATFLAG : 0x05000008
SERIALNO : 5B1833T49443 
BATTDATE : 2018-08-17
NOMINV   : 230 Volts
NOMBATTV : 12.0 Volts
FIRMWARE : 870.O4 .I USB FW:O4
END APC  : 2020-04-03 10:28:05 +0200 

Le service apcupsd est bien actif. sudo systemctl status apcupsd.status  renvoie :
● apcupsd.service - APC UPS Power Control Daemon for Linux
   Loaded: loaded (/usr/lib/systemd/system/apcupsd.service; enabled; vendor pre>
   Active: active (running) since Thu 2020-04-02 19:15:10 CEST; 15h ago
 Main PID: 1258 (apcupsd)
    Tasks: 3
   CGroup: /system.slice/apcupsd.service
           └─1258 /usr/sbin/apcupsd -b -f /etc/apcupsd/apcupsd.conf

avril 02 19:15:10 linux-q3fi systemd[1]: Starting APC UPS Power Control Daemon >
avril 02 19:15:10 linux-q3fi systemd[1]: Started APC UPS Power Control Daemon f>
avril 02 19:15:10 linux-q3fi apcupsd[1258]: apcupsd 3.14.14 (31 May 2016) suse >
avril 02 19:15:10 linux-q3fi apcupsd[1258]: NIS server startup succeeded

Voilà mon souci. Avez-vous une idée sur comment avancer dans le diagnostique ?

Merci !

A+




Re : APC Back-UPS ES550 ne bascule plus sur batterie

Répondre #1
Bonjour

Nouvelles du jour...

J'ai trouvé sur un site (forum de hardware.fr où j'ai acheté l'appareil) des valeurs de tension pour tester la batterie.
Avec un volt-mètre, j'ai mesuré 13,4V aux bornes de la batterie, après l'avoir retirée. Au-delà de 13V, la batterie est en bonne santé et en-dessous de 12V il faut la changer.
Donc, le problème ne doit pas venir de la batterie.

L'onduleur est branché derrière un boîtier CPL. Cela avait fonctionné avec, lors de mes tests et d'une coupure. Je vais essayer sans pour voir, au cas où...
Je pense que je vais contacter l'assistance APC aussi. Cela sent le retour en garantie. Si la garantie est bien de 3 ans, je dois être bon.

Si vous avez des idées, je suis toujours preneur !

A+