Aller au contenu principal
Sujet: Problème Dolphin et Freebox (Lu 926 fois) sujet précédent - sujet suivant

Problème Dolphin et Freebox

Bonjour,

Je viens d'installer Opensuse tumbleweed et quand je veux aller sur ma freebox, j'ai ce message ...

Problème interne.
Veuillez envoyer un rapport de bogue complet à https://bugs.kde.org
Condition d'erreur inconnue dans l'état : Le logiciel a provoqué l'abandon de la connexion

De même, si de mon smartphone, si j'envoie une photo vers dolphin , cela fonctionne mais pas dans l'autre sens. Je penses que cela a un rapport.

Merci de votre aide.

PS : J'ai essayé la même manip avec Nautilus, message d'erreur également.

Re : Problème Dolphin et Freebox

Répondre #1
Bonsoir,

Dolphin n'est pas un navigateur internet. Si tu veux consulter ton interface box, il vaut mieux passer par Firefox ou Falkon.

Concernant ton smartphone, as-tu essayé KDE Connect ?

Re : Problème Dolphin et Freebox

Répondre #2
Je veux accéder au disque dur de ma freebox via dolphin. Pour kdeconnect, je peux envoyé une image vers le pc mais pas le contraire.

Re : Problème Dolphin et Freebox

Répondre #3
Salut,

Je crois qu'il faut vérifier que le protocole mdns est autorisé en zone public sur le firewall.


à plus,
oh!rocks

Re : Problème Dolphin et Freebox

Répondre #4
j'ai désactivé de firewall sans succès ...

Re : Problème Dolphin et Freebox

Répondre #5
Et ta box ? Est-elle configurée pour le partage avec un système Linux ?

(de mémoire, ça se configure sur le site de free, dans ton espace client)


à plus,
oh!rocks

Re : Problème Dolphin et Freebox

Répondre #6
Oui, j'ai aussi sur mon pc kubuntu et pop!os et aucun problème.


Re : Problème Dolphin et Freebox

Répondre #8
J'ai un problème samba surtout  :o

Re : Problème Dolphin et Freebox

Répondre #9
Bonsoir,
Est-ce que tu te rappelles comment tu avais fait la configuration sur kubuntu ?

Re : Problème Dolphin et Freebox

Répondre #10
Pour ma freebox, j'ai rien fait du tout que ce soit sout kubuntu, Pop!Ok. là, je viens de booter sur gecko, basé sur Opensuse, j'ai accès à ma freebox sans problème. Par contre, si je fais :

ace66130@linux-4otz:~> systemctl  status smb.service
● smb.service - Samba SMB Daemon
   Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2019-11-13 19:35:32 CET; 4min 45s ago
  Process: 1796 ExecStartPre=/usr/share/samba/update-apparmor-samba-profile (code=exited, status=0/SUCCESS)
  Process: 1811 ExecStart=/usr/sbin/smbd --foreground --no-process-group $SMBDOPTIONS (code=exited, status=255/EXCEPTION)
 Main PID: 1811 (code=exited, status=255/EXCEPTION)
   Status: "Starting process..."

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

 

Re : Problème Dolphin et Freebox

Répondre #11
Salut :)
J'ai aussi une freebox, la mini 4K et j'ai pris ce matin le temps de tester
Mon portable est sur WiFi. et le pare-feu est activé et en mode public sur wlan0
sudo firewall-cmd --state
[sudo] Mot de passe de root :
running
 sudo firewall-cmd --get-active-zones
public
  interfaces: wlan0
Je lance dolphin puis à gauche je clique sur Réseau > Dossiers partagés (SMB).
J'ai alors un message d'erreur indiquant "Aucun groupe de travail n'a été trouvé ...".
Je ferme ce message. Voir l'image "1_aucun_groupe" attachée à ce message.
Ensuite je fais un clic droit sur smb > modifier et je rentre l'ip 192.168.0.254 puis j'appuie sur la touche Entrée pour valider.
Le disque dur externe USB relié à la freebox apparaît alors.
Chez moi, je l'ai appelé DATA_WESTERN. Voir l'image "2_clic droit modifier" attachée à ce message
j'ai fait un clic droit sur ce dossier DATA_WESTERN > Ajouter aux emplacements appropriés pour qu'il apparaisse à gauche sous réseaux.
Il me reste à redémarrer le PC pour vérifier que le disque dur est toujours visible et accessible et aussi voir ce qui se passe si je l'enlève de la box.
Edit :
Après redémarrage, c'est toujours bon. Le dossier est présent dans réseaux et j'accède à son contenu.
Après avoir démonté le disque externe depuis freebox OS en cliquant sur le dossier mis en raccourci à gauche dans dolphin on a seulement le message "le fichier ou dossier smb://192.168.0.254/DATA_WESTERN"  n'existe pas. Pas de plantage de dolphin.
En réactivant le disque (soit par FreeboxOS ou en débranchant/rebranchant à la freebox) le dossier est de nouveau accessible. J'ai pu lire une vidéo, en supprimer une autre  donc ça me semble bon tout ça :D
En complément l’ip 192.168.0.254 est celle de la freebox, pour une autre box ce pourra être 192.168.1.0 ou ... c’est l’adresse qui permet d'accéder aux réglages de la box.

Re : Problème Dolphin et Freebox

Répondre #12
Bonjour,
je possède une box orange et cette méthode (entrer l'adresse IP) fonctionne très bien pour elle aussi. Maintenant, puisque ces "problèmes" viennent de la configuration du pare feu, je me pose la question de son utilité car la box a son propre pare feu.
En tous cas, merci pour l'astuce.

Re : Problème Dolphin et Freebox

Répondre #13
Bonjour,
Merci du retour pour les boxs orange :)
Chez moi pare-feu activé ou non, ça se passe de la même façon maintenant je suis très loin de maîtriser tout ça.
En tout cas, depuis que j’ai le raccourci du disque dur branché sur la box, pas de souci.

Re : Problème Dolphin et Freebox

Répondre #14
En cherchant, je suis tombé sur un post du forum anglophone.

Explication:
Citer
"Browsing" network fails with "Failed to retrieve share list from server"

And you are using a firewall (iptables) because you do not trust your local (school, university, hotel) network. This may be due to the following: When the smbclient is browsing the local network it sends out a broadcast request on udp port 137. The servers on the network then reply to your client but as the source address of this reply is different from the destination address iptables saw when sending the request for the listing out, iptables will not recognize the reply as being "ESTABLISHED" or "RELATED", and hence the packet is dropped. A possible solution is to add:
iptables -t raw -A OUTPUT -p udp -m udp --dport 137 -j CT --helper netbios-ns

Interpretation :) :
C'est une histoire de résolution de nom d’hôte. Pour ce faire notre ordinateur envoie un broadcast sur le port 137 à tous les serveurs samba (les ordinateurs ayant quelque chose à partager...) avec naturellement l'adresse broadcast: 192.168.1.255 (pour un réseau local 192.168.1.0/24), dans le but d'obtenir le nom d’hôte de ces serveurs samba (un ordinateur, une freebox revolution, un NAS...) ainsi que leur IP correspondante. Nos paquets auront donc comme IP source la notre (192.168.1.2), et comme IP cible 192.168.1.255.

Si un serveur nous répond positivement, il utilisera notre adresse ip comme 'IP cible' (192.168.1.2) et la sienne comme 'IP source' par exemple 192.168.1.3.

Deux problèmes:
  • L'IP cible de notre requête, le broadcast 192.168.1.255 n'est pas la même que l'IP source de la réponse 192.168.1.3
  • La connexion entre nous, le client, et le serveur n'a pas encore le statut 'Etabli'
Le firewall bloque ainsi la réponse du serveur, il fait son job. Ça a à voir avec 'conntrak, helpers de Netfilter' (je ne connais pas suffisamment... En cherchant un peu on trouve)

Remarque:
C'est pour cela que l'on peut accéder manuellement à un serveur samba en tapant directement son IP, par exemple smb://192.168.1.254 , la résolution du nom d’hôte n'entre pas en ligne de compte.

Solution: (en root)
# firewall-cmd --set-automatic-helpers=yes

Ça marche aussi graphiquement avec 'firewall-config': Options > Configure Automatic Helper Assignment > Yes .