Aller au contenu principal
Sujet: Open suse LEAP ne boot pas sur mon Thinkpad T420 (Lu 163 fois) sujet précédent - sujet suivant

Open suse LEAP ne boot pas sur mon Thinkpad T420

Bonjour,

Etant dev dans le web, je me suis tourner vers OPEN SUSE comme distri.
C'est super ça marche du feu de dieu !!! Sur KDE quel pied.

Cependant j'ai un gros soucis. Je ne parviens qu'a faire démarrer la distribution qu'avec la clé USB d'install en selectionnant BOOT FROM HARDISK.

C'est facheux, quand je démarre le PC sans la clé, rien ne se passe, je pense qu'il un problème au niveau du boot.
A l'installation, j'ai bien crée une partition de type BIOS BOOT ainsi qu'une partition qui va sur /boot
Mon PC a l'UEFI et je l'ai desactivé.
J'ai vu qu'on pouvait configurer sur YAST, j'ai choisis ces options, sans succés:



Y'a t'il une solution ?

Merci, Thomas.

Re : Open suse LEAP ne boot pas sur mon Thinkpad T420

Répondre #1
Bonjour,

Le disque est formaté avec une table des partitions DOS ou GPT ?
Ou est située sur le disque la partition BOOT ?

Un petit fdisk -l  en root pourrait aider !

Re : Open suse LEAP ne boot pas sur mon Thinkpad T420

Répondre #2
Voici le resultat de la commande:



Il me semble ne pas l'avoir formater a l'installation...  ::)

Re : Open suse LEAP ne boot pas sur mon Thinkpad T420

Répondre #3
pourquoi désactiver l'UEFI?

sa fait pas mal de temps que j'ai pas configurais un pc en non UEFI.

mais dans mes souvenir il fallait:
- avoir un partitionnement en msdos (aujourd'hui on est gpt)
- avoir activé le drapeaux bootable sur la partitions.
- configurer grub sur le mbr
- avoir bien paramétrer le bios.

David

Re : Open suse LEAP ne boot pas sur mon Thinkpad T420

Répondre #4
Aie je la possibilité d'ajouter ce drapeau boot ?

Merci.

Re : Open suse LEAP ne boot pas sur mon Thinkpad T420

Répondre #5
Salut, regarde dans les options du boot. Sùr moon ThinkPad(bios à jour), j'ai Windows boot manager ou le nom du disque comme option de boot.
J'ai aussi les options boot legacy,boot uefi ou les deux.si je veux démarrer sursuse,je sélectionne le nom du disque et lega.cy seulement.
Mais depuis je suis passé en mode efi en montant dans fstab la partition efi Windows.
Maintenant,dans le bios une nouvelle ligne est apparue: opensuse bootloader . Dans le  grub,j'ai maintenant le choix entre les deux systèmes.
Regarde dans mes sujets postés.
https://www.alionet.org/index.php?topic=334.msg2702#msg2702

Re : Open suse LEAP ne boot pas sur mon Thinkpad T420

Répondre #6
Salut,
Je pense que tu as raté ton installation quelque part. Si tu n'as pas encore trop tout configuré dans tout les sens, tu aurais meilleur compte de réinstaller.
Tu n'as strictement aucune raison de ne pas utiliser l'UEFI, ton PC le prend en charge et ton disque est bien formaté en utilisant GPT.
Si tu n'es pas sûr de ce que tu fais, je te conseille de suivre le partitionnement par défaut de l'installateur (ou une des alternatives proposées).