Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Comment réparer le multiboot ? (Lu 337 fois) sujet précédent - sujet suivant

Comment réparer le multiboot ?

Bonjour,
Je viens de m'apercevoir que Windows a disparu de mon multiboot. Et le pire, c'est que je pense que c'est arrivé suite à sa mise à jour. Windows qu se fait Hara-kiri. Délire !
Bref ! Je sais pas trop par où attaquer. Je suppose que je suis sur Bios mais je vois que ca parle d'uefi de partout sur Internet.
Avant, quand j'allais dans les parametres du chargeur d'amorçage, j'avais "windows" dans les paramètres. Là, il n'y a plus que OpenSuse.
Je suis sur GRUB2 et l'amorçage est sur le MBR.
Windows 10 est sur sda2.
Pouvez vous m'éclairer ?
Cdt

Re : Comment réparer le multiboot ?

Répondre #1
salut.
est ce que windows est reconnu ? fdisk -l pour voir ton partitionnement.
Dans yast,chargeur d'amorçage, reconnaissance des autres os est elle cochée?
essaye os-prober en terminal.
après tu fais
grub2-mkconfig -o /boot/grub2/grub.cfg
tu verras si windows apparait.

Re : Comment réparer le multiboot ?

Répondre #2
Terrific !!
Merci, c'est nickel.
je n'ai pas encore redémarré, mais Windows est réapparu dans le chargeur... donc, à moins qu'il y ait un lutin numérique pour me faire une farce, ca doit être résolu :-)
Petit détail pour de futurs chercheurs de Windows disparu, ca n'est pas "osprober", mais "os-prober".
En tous cas, merci bien !

j'ai corrigé,merci
jtro