Aller au contenu principal
Sujet: Blocage de touche mise en veille sur mon clavier (Lu 184 fois) sujet précédent - sujet suivant

Blocage de touche mise en veille sur mon clavier

Bonjour la communauté,
mon clavier "cherry" dispose d'une touche de mise en veille (logo d'une lune) juste au dessus de la touche tiret du pavé numérique.
Je cherche sans trouver le moyen de désactiver cette touche pour qu'elle ne fasse plus rien.

Actuellement, la touche provoque un "suspend to RAM" je pense (le bouton power de mon PC clignote et en réappuyant dessus je me retrouve sur la mire de login Gnome).

J'utilise actuellement OpenSUSE Leap 15.1 et l'environnement Gnome 3.

J'ai essayé bien sûr d'aller dans la configuration des touches clavier mais rien ne se réfère à ce bouton clavier "mise en veille".
j'ai également essayé le menu "énergie" mais seul le bouton d'extinction peut-être paramétré.

En lisant d'autre forum, j'ai utilisé dconf-editor pour essayer de trouver des entrées "suspend" mais ces clés n'ont pas l'air d'exister sous OpenSUSE :
franck-tour-rj:~ # gsettings list-keys org.gnome.settings-daemon.plugins.power
power-button-action
idle-dim
sleep-inactive-ac-type
sleep-inactive-battery-timeout
disable-touch-screen
sleep-inactive-battery-type
sleep-inactive-ac-timeout
ambient-enabled
idle-brightness

Auriez-vous une idée du comment intercepter ce bouton "mise en veille" pour qu'il ne fasse plus rien ? Merci.

Cordialement,
Franck

Re : Blocage de touche mise en veille sur mon clavier

Répondre #1
Bonjour et bienvenue !!

Quand tu lances l'appication Paramètres et que tu te rends dans l'onglet "énergie" as-tu la même chose?



Si c'est le cas vérifie bien que le automatic suspend, soit bien sur désactivé.

Peux-tu me donner le retour de la commande :

cat /etc/systemd/logind.conf

Ainsi que de :

sudo journalctl --boot=-1 | tail -n120

S'il te plait?

Vigen.

 

Re : Blocage de touche mise en veille sur mon clavier

Répondre #2
Salut,

Peux-tu nous préciser le modèle du clavier Cherry ?
Généralement ce genre de touche doit être utilisée en conjonction avec une pression sur la touche Fn, est-ce le cas également ?
Sinon l'utilitaire "xev" (du paquet du même nom) peut être utilisée pour avoir plus d'info sur une touche (bon là le soucis c'est que ça va mettre ton PC en veille mais tu devrais avoir le résultat en sortie de veille).
Enfin, tu peux également essayer de la réaffecter via les paramètres Gnome (Paramètres => Raccourcis clavier).

J'espère juste que ce n'est pas une touche dont la fonction, codée en dur, envoie un signal ACPI.

Re : Blocage de touche mise en veille sur mon clavier

Répondre #3
Bonjour Vigel, bonjour Sogal,
merci pour vos réponses.

Alors, dans le désordre :

- Le modèle de mon clavier Cherry est "Cherry DW 5100"

- Je n'ai pas de touche "Fn" sur mon clavier, les touches de fonction sont directement accessibles et cette touche "mise en veille" n'a pas besoin d'être utilisée combo avec une autre touche (touche méta)

- J'ai essayé comme suggéré de réaffecter une touche de raccourci mais dès que j'appuie sur cette touche "mise en veille" et bien ... ça passe en veille  :)

- Oui Sogal, comme toi je me demande si cette touche n'est pas directement interceptée par HAL dû à un mode de gestion  de l'ACPI

- Voici ce que me m'indique la partie "Énergie" de Gnome
Bouton de mise en veille et extinction
Mise en veille automatique : désactivée
Lorsque le bouton d'extinction est enfoncé : Rien

- Voici mon logind.conf et là je vois une entrée "#HandleHibernateKey=hibernate". Passer cette option à "ignore" serait peut-être une solution Vigen. Qu'en penses-tu ?
franck-tour-rj:~ # cat /etc/systemd/logind.conf
#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See logind.conf(5) for details.

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
HandleSuspendKey=ignore
#HandleHibernateKey=hibernate
#HandleLidSwitch=suspend
#HandleLidSwitchDocked=ignore
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes
#HoldoffTimeoutSec=30s
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RemoveIPC=no
#InhibitorsMax=8192
#SessionsMax=8192
#UserTasksMax=33%

- Pas de résultat sur le journal par contre :
franck-tour-rj:~ # sudo journalctl --boot=-1 | tail -n120
Specifying boot ID or boot offset has no effect, no persistent journal was found.


Cordialement,
Franck


Re : Blocage de touche mise en veille sur mon clavier

Répondre #4
Bonjour à tous,
le problème est bien lié à la capture de l'évènement "suspend" géré par systemd.

J'ai essayé de masquer la target suspend :
franck-tour-rj:~ # systemctl mask suspend.target
Created symlink /etc/systemd/system/suspend.target → /dev/null.

et là, quand j'appuie sur la touche mise en veille du clavier, le PC ne passe plus en mode "suspendu". Par contre, j'ai un effet de bord indésirable car il ferme la session active et me ramène à l'écran de login de Gnome.

Franck.