Aller au contenu principal
Sujet: Carte graphique ATI Radeon HD 4670 sur iMac 2010 non prise en charge (Lu 443 fois) sujet précédent - sujet suivant

Re : Carte graphique ATI Radeon HD 4670 sur iMac 2010 non prise en charge

Répondre #15
ah super :) et l'affichage est meilleur pour le bureau ?

Rien de flagrant, l'animation des fenêtres reste saccadée, idem pour les vidéos.  :-\

Citer
qu'est ce que tu as comme retour de la commande , une fois que tu es sur le bureau :
sudo lspci -nnk |grep -iA3 vga


J'ai ça :

# lspci -nnk |grep -iA3 vga
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV730/M96-XT [Mobility Radeon HD 4670] [1002:9488]
        Subsystem: Apple Inc. Device [106b:00b6]
        Kernel modules: radeon
01:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] RV710/730 HDMI Audio [Radeon HD 4000 series] [1002:aa38]


Re : Carte graphique ATI Radeon HD 4670 sur iMac 2010 non prise en charge

Répondre #16
oui ce n'est pas étonnant puisque la carte n'est pas utilisée avec tout "son potentiel"
Tu es sur une nouvelle installation du système que tu as fait hier c'est ça ? donc xf86-video-ati est installé ?
Si à la place de nomodeset et/ou de radeon.modeset=0 tu écris :
radeon.dpm=0

est-ce que tu arrives à atteindre le bureau ?

Est-ce que tu as testé openSUSE KDE en Live ? ça fonctionnait comment ? le retour de la commande
sudo lspci -nnk |grep -iA3 vga
c'était quoi ?

Re : Carte graphique ATI Radeon HD 4670 sur iMac 2010 non prise en charge

Répondre #17
Tu es sur une nouvelle installation du système que tu as fait hier c'est ça ? donc xf86-video-ati est installé ?

Exact.

J'ai oublié de préciser que j'ai toujours au démarrage le message "No UMS support in radeon module!"

Citer
Si à la place de nomodeset et/ou de radeon.modeset=0 tu écris :
radeon.dpm=0

est-ce que tu arrives à atteindre le bureau ?

Non, ca plante toujours au même endroit, comme à la première install.

Citer
Est-ce que tu as testé openSUSE KDE en Live ? ça fonctionnait comment ? le retour de la commande
sudo lspci -nnk |grep -iA3 vga
c'était quoi ?

Je viens de tester Leap Live-KDE :
  • Avec les paramètres par défaut, écran noir habituel.
  • J'arrive sur le bureau en ajoutant nomodeset comme d'hab.

# lspci -nnk |grep -iA3 vga
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV730/M96-XT [Mobility Radeon HD 4670] [1002:9488]
        Subsystem: Apple Inc. Device [106b:00b6]
        Kernel modules: radeon
01:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] RV710/730 HDMI Audio [Radeon HD 4000 series] [1002:aa38]

J'obtiens le même résultat si je remplace nomodeset par radeon.dpm=0.

Re : Carte graphique ATI Radeon HD 4670 sur iMac 2010 non prise en charge

Répondre #18
Si une fois que tu as démarré avec l'option radeon.modeset=0 et que tu arrives sur le bureau, si tu fais

sudo modprobe radeon radeon.modeset=1
est-ce que ça change quelque chose sur l'affichage ?
que retourne alors la commande
sudo lspci -nnk |grep -iA3 vga

Sinon est-ce que tu as essayé plasma avec wayland ?
je pense que la version de kde actuelle pour leap 15.1 n'est pas encore bien au point, il devrait y avoir du mieux dans celle de leap 15.2


Re : Carte graphique ATI Radeon HD 4670 sur iMac 2010 non prise en charge

Répondre #19
~> sudo modprobe radeon radeon.modeset=1
modprobe: ERROR: could not insert 'radeon': Invalid argument

Je viens de découvrir l'existence de Wayland. Je ne suis pas sûr de bien avoir compris de quoi il s'agissait (je sors de plus de dix ans sans Linux, et mes compétences en informatique restent extrêmement limitées).

J'ai tenté d'ouvrir une session avec Wayland + KDE. Freeze instantané sur l'écran de login, pas moyen d'accéder à un tty...  =>Hard reboot.

Penses-tu que ma carte graphique pourrait être mieux prise en compte si j'utilisais Gnome avec Wayland ? Je peux toujours tester avec un compte utilisateur créé pour l'occasion, mais Gnome prend tout de même beaucoup de place (même si je devrais rester large avec 20 Go pour ma partition système) et d'expérience après c'est difficile de désinstaller un environnement de bureau car on se trouve empêtré dans tout un tas de dépendances...

Et crois-tu que ça vaille la peine de tester 15.2 pour voir ? J'ai gardé 80 Go non alloués en fin de disque :D

Ce qui m'épate, c'est de ne pas avoir trouvé une seule distribution avec laquelle ma carte graphique fonctionne correctement dans ma configuration sans bidouillage, alors que c'est un vieux modèle éprouvé, avec un driver qui a dû bien faire ses preuves.

Re : Carte graphique ATI Radeon HD 4670 sur iMac 2010 non prise en charge

Répondre #20
Comme tu es encore à l'étape des tests sur ce PC, oui j’essaierais Gnome mais aussi Xfce.

Re : Carte graphique ATI Radeon HD 4670 sur iMac 2010 non prise en charge

Répondre #21
Sinon, je n’ai pas donné la bonne commande plus haut.
si tu n’avais pas corrigé tu peux réessayer de démarrer avec l’option nomodeset.radeon=0
puis une fois la session démarrée faire
sudo modprobe radeon modeset=1
Tu peux essayer cette commande après t'être connecté
Ou bien en arrivant sur l'écran de connexion sddm
Tu passes dans un tty et tu te connectes et fais cette commande puis te repasses en graphique.
On accède au tty avec Carl+Alt+F1 ou F2 et le retour au graphique c’est F7

Re : Carte graphique ATI Radeon HD 4670 sur iMac 2010 non prise en charge

Répondre #22
tu peux réessayer de démarrer avec l’option nomodeset.radeon=0
puis une fois la session démarrée faire
sudo modprobe radeon modeset=1


Ecran noir immédiat sur tty1, plus moyen de voir quoi que ce soit, en tty1, 2, 3, 7...


Re : Carte graphique ATI Radeon HD 4670 sur iMac 2010 non prise en charge

Répondre #23
Au niveau des environnements (j'ai installé à peu près tout ce que je pouvais), je dois démarrer avec quelle option et faire quels tests ?

Pour l'instant, j'ai testé :
  • Une session Weston ; j'obtiens un écran noir avec juste un prompt clignotant, si je vais sur tty7 je ne vois que l'écran noir avec le curseur de la souris, puis je peux revenir aux différents tty (j'ai relancé ma session normale en faisant "rcxdm stop" puis "rcxdm start" en root)
  • Avec enlightment (j'aime bien cet environnement :) ) malgré les graphiques effets sympas par défaut,  ca reste saccadé et pas très beau.
  • Avec LXDE non plus

En tout j'ai les choix suivants :

  • Enlightment
  • Gnome classic
  • Gnome on Xorg
  • Gnome
  • IceVM Session
  • LXDE
  • LXQt Desktop
  • MATE
  • Openbox
  • Plasma
  • SLE Classic
  • TVM
  • Xfce Session
  • GNOME
  • Plasma (Wayland)
  • SLE Classic
  • Weston



Re : Carte graphique ATI Radeon HD 4670 sur iMac 2010 non prise en charge

Répondre #24
Tu sembles avoir tiré le mauvais lot avec une carte graphique qui a un problème avec le pilote radeon.
il reste donc à le blacklister mais les performances seront moindre, enfin pas trop le choix. je n’ai pas trouvé de solution.
Pour les environnements du coup il faudrait du léger, sans effets qui sollicitent la carte. Je dirais lxqt ? 

Si tu veux, tu peux poser ton problème sur le forum anglais d’openSUSE, avec un peu de chance tu auras des gens avec le même matériel.

Re : Carte graphique ATI Radeon HD 4670 sur iMac 2010 non prise en charge

Répondre #25
Bon je vais faire avec et explorer les possibilités qui s'ouvrent à moi.

Merci pour ton aide !

 

Re : Carte graphique ATI Radeon HD 4670 sur iMac 2010 non prise en charge

Répondre #26
Salut,

As-tu tenté de faire la manip suivante:
  * installer opensuse en mode serveur
  * puis installer le driver propriétaire ATI pour ta carte (voir sur le site d'ATI)
  * eventuellement installer X (le sous-systeme graphique)
  * redémarrer et taper startx

vieille méthode mais qui a déjà fait ses preuves quand les drivers graphiques posaient problème ...

@+

Sfx

Re : Carte graphique ATI Radeon HD 4670 sur iMac 2010 non prise en charge

Répondre #27
Bonjour silfax, et merci de ta suggestion,

Le souci est que le driver propriétaire d'ATI n'est valable que jusqu'à la version 1.12 de X server et 3.4 du noyau Linux, voir ATI Radeon™ HD 4670 Drivers & Support.

Re : Carte graphique ATI Radeon HD 4670 sur iMac 2010 non prise en charge

Répondre #28
Penses-tu que ça pourrait marcher avec le driver libre actuel ?

Re : Carte graphique ATI Radeon HD 4670 sur iMac 2010 non prise en charge

Répondre #29
le driver libre c’est le driver radeon mais ta carte n’est pas compatible... alors qu’elle le devrait.