Aller au contenu principal
Sujet: explorateur réseau accès NAS impossible (Lu 338 fois) sujet précédent - sujet suivant

Re : explorateur réseau accès NAS impossible

Répondre #15
Bonjour

Je pense avoir le même problème que Yoman sur mon PC de bureau avec Manjaro.
Je peux me connecter en smb://ip_adress/folder mais je ne vois pas le disque partagé par ma Freebox.

En fouillant un peu, j'ai vu que je n'avais pas de smb.conf ; mais cela ne m’empêchait pas de me connecter sur smb://........
J'en ai créé un mais pas mieux.

Au final, ce qui a fonctionné a été de démarrer le service suivant :
systemctl start avahi-daemon

Il parait aussi qu'il faut avoir la ligne ci-dessous dans son smb.conf pour des questions de compatibilité de protocol :
client max protocol = NT1

A essayer peut-être ?

A+


Re : explorateur réseau accès NAS impossible

Répondre #17
Bonjour

Je pense avoir le même problème que Yoman sur mon PC de bureau avec Manjaro.
Je peux me connecter en smb://ip_adress/folder mais je ne vois pas le disque partagé par ma Freebox.

En fouillant un peu, j'ai vu que je n'avais pas de smb.conf ; mais cela ne m’empêchait pas de me connecter sur smb://........
J'en ai créé un mais pas mieux.

Au final, ce qui a fonctionné a été de démarrer le service suivant :
systemctl start avahi-daemon

Il parait aussi qu'il faut avoir la ligne ci-dessous dans son smb.conf pour des questions de compatibilité de protocol :
client max protocol = NT1

A essayer peut-être ?

A+
@squid-f

Merci pour l'info , je vais tester ça ...👍

Re : explorateur réseau accès NAS impossible

Répondre #18
Salut :)
As-tu avancé ?
Chez moi le service avahi est déjà activé, j’ai testé mes lecteurs multimedia.
Vlc aucun problème j'accède via le raccourci ajouté dans Dolphin au disque dur branché sur l’a box en utilisant fichier>ouvrir dans vlc
La lecture se lance bien.
Par contre avec smplayer, amarok ou clémentine la lecture ne se lance pas
Si j’utilise dolphin pour naviguer jusqu’au disque dur et choisis l’un de ces logiciels dans le clic droit > ouvrir
La lecture se lance mais je vois un message ,caché/run kio (bon je n’ai pas noté les termes exacts)
Le fichier est téléchargé dans le dossier .cache du home et il est lu.

Re : explorateur réseau accès NAS impossible

Répondre #19
Re -bonsoir

Merci pour tout vos retours.

Nop. Pas avancé, je vais re-tenté la config dans smb.con

client max protocol = NT1

J'avais déjà éssayé un jour, mais rien, mais d'ici peut-être que ça a changer. 

avahi-daemon est bien lancé au démarrage.
Il me manque a tenté le mdns, je me documente pour voir.

Encore merci, a tous, mais je sais que je le ferais fonctionné sans passé par un montage NFS ,. (mais quand ??, lol)

Re : explorateur réseau accès NAS impossible

Répondre #20
Salut,
client max protocol = NT1
Ça ne me semble pas une bonne idée de mettre max
J’ai lu ce fil du forum anglais
NT1 serait un protocole SMB1 déprécié qui poserait des problèmes de sécurité
Post #26 il est indiqué qu’en mettant dans /etc/samba/smb.conf dans la section [global]
client min protocol = NT1
Ça a fonctionné

Re : explorateur réseau accès NAS impossible

Répondre #21
re @chalu‍ 

Merci, je ne le savais pas et pourtant je suis très a cheval sur la sécurité, donc je laisse tombé l'idée de NT1

Merci

Re : explorateur réseau accès NAS impossible

Répondre #22
Bonjour

A toutes fins utiles, voici mon fichier smb.conf :
[global]
   workgroup = WORKGROUP
   dns proxy = no
   log file = /var/log/samba/%m.log
   max log size = 1000
   client max protocol = NT1
   server role = standalone server
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
   pam password change = yes
   map to guest = Bad Password
   usershare allow guests = yes
   name resolve order = lmhosts bcast host wins
   security = user
   guest account = nobody
   usershare path = /var/lib/samba/usershare
   usershare max shares = 100
   usershare owner only = yes
   force create mode = 0070
   force directory mode = 0070

Merci @chalu , je vais regarder cette histoire de protocol NT1.

Edit : que donne la commande suivante : testparm | more

A+

Re : explorateur réseau accès NAS impossible

Répondre #23
L’intervenant sur le fil donné en lien dans mon message semble assez sûr de lui, c’est post #24
Citer
Good to read of your progress here, however you should check if connectivity to this server really does rely on the SMB1 (NT1 protocol), as it is a significant security risk when enabled, and has been deprecated for good reason.
Citation de: traduction
C’est bien de lire vos progrès ici, cependant vous devriez vérifier si la connectivité à ce serveur repose vraiment sur le protocole SMB1 (protocole NT1), car c'est un risque de sécurité important lorsqu'il est activé, et il a été déprécié pour de bonnes raisons.

De mon côté, je suis satisfaite de la solution trouvée pour mettre mon disque dur branché sur la box en raccourci sur la gauche de dolphin. J’ai ainsi accès à tout le contenu sans problème.
VLC fonctionne bien,  fichier> ouvrir depuis le logiciel me permet de lancer les fichiers audios et vidéos
amarok et smplayer fonctionnent seulement si je les lance depuis dolphin avec un clic droit
Pourtant en ligne de commande, ça fonctionne
smplayer smb://192.168.0.254/disque/vidéo.mp4
Je me demande si c’est un problème KDE ou plutôt ces logiciels qui n’ont pas les protocoles qu’il faut puisque vlc fonctionne.

Je vais peut-être (sans doute :D ) dire une bêtise mais testparm c’est pour tester les paramètres du serveur non ? Là c’est le client avec openSUSE qui ne fonctionne pas comme sur d’autres distributions.

Re : explorateur réseau accès NAS impossible

Répondre #24
Je vais peut-être (sans doute :D ) dire une bêtise mais testparm c’est pour tester les paramètres du serveur non ? Là c’est le client avec openSUSE qui ne fonctionne pas comme sur d’autres distributions.

Bonjour @chalu
Je pense que tu es beaucoup plus qualifié que moi ! Donc, c’est plus moi qui peut dire des bêtises !
En fait, j’aurais tendance à être d’accord avec toi et, si j’ai proposé cette commande, c’est qu’elle permet apparemment de tester le fichier smb.conf qu’on cherche désespérément modifier.
Par contre, effectivement, je pense que d’un point de vue machine cliente, cela n’a pas bien d’importance (là, c’est moi qui pourrait dire une bêtise !).
En effet, j’ai réussi à me connecter à mon serveur samba sans fichier smb.conf sur la machine cliente.

J’ai effacé la commande liée au protocole NT1 et cela fonctionne toujours (i.e je vois tous les disques du réseau sans avoir à explicitement chercher un répertoire par smb://ip/dossier).

Ce qui a fait la différence a été le chargement et le lancement du service avahi-daemon.
Perso, je continuerais à creuser cette voie ou autres services KDE.

A+

Re : explorateur réseau accès NAS impossible

Répondre #25
@squid-f

Bizzard , car j'ai avahi daemon aussi en service , et rien au niveau explorateur réseaux.... 

Re : explorateur réseau accès NAS impossible

Répondre #26
Citation de: squid-f
cela fonctionne toujours (i.e je vois tous les disques du réseau sans avoir à explicitement chercher un répertoire par smb://ip/dossier).
Dans la partie centrale de dolphin ? Est-ce que tu peux faire une capture d'écran ?
Jusqu’à présent je n’avais pas de disque sur la box donc ça m’aiderait de voir à quoi ressemble un usage normal :)

Re : explorateur réseau accès NAS impossible

Répondre #27
Jusqu’à présent je n’avais pas de disque sur la box donc ça m’aiderait de voir à quoi ressemble un usage normal :)
[/quote]
Salut @chalu

Voici une copie d'écran. Je suis sous Gnome (et Manjaro) pour ce PC "client". Le portable de ma fille qui est encore sous Linux Mint (à la prochaine mise à jour, je lui proposerai Leap  ;)  ), présente le même type de vue avec Nemo.
Je vois les 2 machines serveurs : la Freebox et mon HTPC (sous Leap).

A+

Re : explorateur réseau accès NAS impossible

Répondre #28
Bonjour à vous

En manipulant le pare-feu pour connecter une imprimante réseau à mon serveur sous Leap (qui a aussi un répertoire partagé via samba), je me suis aperçu que les autres disques Samba (comme la Freebox) apparaissaient !

@yoman , as-tu essayé d’arrêter le pare-feu et de voir si cela autorisait à voir tes autres disques partagés par samba ?
Éventuellement, déconnecter et reconnecter la session avec le pare-feu arrêté.
Si cela marche, il semble qu’autoriser le service mdns dans le pare-feu me permette de voir les autres disques samba.

A noter que j’ai aussi les services smb et nmb qui sont actifs car le serveur samba est fonctionnel.

A suivre ?

A+