Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Fichiers *.desktop vides associées à des icônes (Lu 225 fois) sujet précédent - sujet suivant

Fichiers *.desktop vides associées à des icônes

Bonjour,

J'utilise  Tumbleweed 20200801 avec KDE Plasma 5.19.4, Qt 5.15.0. Je l'ai installé il y a quelques mois mais ne l'utilise que peu, travaillant sur Leap. Tout semble fonctionner correctement à part un petit problème:
Les applications YasT et snapper ne peuvent pas être lancées à partir de leurs icônes respectives. Le message suivant apparaît alors:
"Impossible d'exécuter la commande spécifiée. Le fichier ou le dossier /home/piantino/Bureau/snapper.desktop n'existe pas."
En fait les deux fichiers ".desktop" sont vides.
Comment corriger ce problème?
D'avance merci pour votre aide.

Re : Fichiers *.desktop vides associées à des icônes

Répondre #1
Salut,

Je suis sur Tumbleweed et je n'ai pas ce type d'icones...

Sinon, autant YaST que snapper doivent être lancés en root (su ou sudo).


à plus,
oh!rocks

Re : Fichiers *.desktop vides associées à des icônes

Répondre #2
Bonsoir,
Il faut essayer des les effacer soit en essayant avec Bleachbit, soit en faisant un
sudo rm -rf /home/piantino/Bureau/snapper.desktop
(il vaut mieux faire  un ls -rf /home/piantino/Bureau/snapper.desktop avant pour vérifier que des fichiers système ne soient pas effacés).

Re : Fichiers *.desktop vides associées à des icônes

Répondre #3
Merci pour les réponses.

Sur openSUSE Leap 15 les icônes correspondant à snapper et YaSt fonctionnent correctement, bien sûr elles demandent l'identification root. Cela est-il différent sur Tumbleweed ?

Re : Fichiers *.desktop vides associées à des icônes

Répondre #4
Normalement dans ce cas, la commande rm efface les fichiers ou les répertoires (avec l'option -rf) sans les droits root.
On peut vérifier les droits avec la commande ls -l

Re : Fichiers *.desktop vides associées à des icônes

Répondre #5
J'ai été induit en erreur de par le fait que lors de l'installation initiale de Tumbleweed les deux icônes étaient présentes sur le bureau et elles ont été désactivée lors d'une mise à jour. J'ai pu vérifier cela en partant d'un ancien snapshot. Finalement tout est en ordre.