Aller au contenu principal
Sujet résolu
Ce sujet a été marqué résolu et ne nécessite aucune autre attention.
Sujet: Pas mal de logiciels manquants dans les dépôts leap (Lu 437 fois) sujet précédent - sujet suivant

Pas mal de logiciels manquants dans les dépôts leap

Bonjour,

Petite remarque, je trouve vraiment dommages que des logiciels "courants" ne soient pas dans les dépôts principaux.
Exemple seafile:
https://software.opensuse.org/package/seafile-client
C'est un paquet expérimental, ça implique quoi?

X2Go-client:
https://software.opensuse.org/package/x2goclient
X11:RemoteDesktop:x2go Expérimental
Encore un expérimental et en plus ce n'est pas complet, il manque des modules pour que ça s'installe, du coup obligé de se rabattre sur un communautaire (home:ithod:x2go dans mon cas).

Surpris de voir aussi que firefox est toujours en version 78 et non pas 80, c'est une version ESR je suppose?


Re : Pas mal de logiciels manquants dans les dépôts leap

Répondre #2
Merci pour l'information.
Après esr ça va encore vu que la version est récente, ça n'est plus la version 68 donc ça reste acceptable.

Re : Pas mal de logiciels manquants dans les dépôts leap

Répondre #3
J'en connais qui sont passés sous Debian pour avoir des softs plus récents, c'est fonction du besoin, mais je trouve que la distro parfaite existe. Chacune a ses avantages/inconvénients.

Re : Pas mal de logiciels manquants dans les dépôts leap

Répondre #4
J'en connais qui sont passés sous Debian pour avoir des softs plus récents, c'est fonction du besoin, mais je trouve que la distro parfaite existe. Chacune a ses avantages/inconvénients.
Bonjour,

En fait il y a actuellement deux versions ESR de Firefox (68.12.0esr et 78.2.0esr). Je ne sais pas pourquoi...

https://www.mozilla.org/en-US/firefox/all/#product-desktop-esr

Mais curieusement Debian Buster stable est sur la 68.12.0esr et sid (unstable) sur la 78.2.0esr.

https://packages.debian.org/search?keywords=firefox-esr-l10n

Leap correspond en gros à Debian stable mais en ce qui concerne Firefox, Leap dispose de la version ESR la plus récente. Je crois aussi que la version de KDE Plasma est aussi plus fraîche sur Leap (en plus d'être une version LTS si j'ai bien compris). J'avais néanmoins noté il y a quelques temps des choses plus en retrait par contre. En stable, l'avantage de Debian se situe pour moi dans les backports. Sinon, avant d'installer Leap, j'avais brièvement essayé en dur Debian stable KDE. Et là, Leap a largement gagné ma préférence.

Maintenant, à mon niveau la fraîcheur des paquets n'est pas une priorité. J'ai un moment regretté que Darktable par exemple soit en version 2.6.3 (3.0.2 dans les backports de Debian)... mais quoi? Je ne maîtrise pas du tout ce logiciel. Donc commençons par le début, l'apprentissage, et après on verra et il n'est pas dit que les dernières nouveautés m'apportent forcément un gain dans ma pratique (plutôt lègère de la photographie).

Avantages et inconvénients, il faut certes les mesurer mais aussi les peser dans son usage personnel.

Re : Pas mal de logiciels manquants dans les dépôts leap

Répondre #5
Citer
J'ai un moment regretté que Darktable par exemple soit en version 2.6.3 (3.0.2 dans les backports de Debian
Darktable en version 3.2.1 et même 3.3.0 existe dans les dépôts : https://software.opensuse.org/package/darktable
Il ne faut pas hésiter à aller piocher dans les dépôts communautaires.


 

Re : Pas mal de logiciels manquants dans les dépôts leap

Répondre #7
J'en connais qui sont passés sous Debian pour avoir des softs plus récents, c'est fonction du besoin, mais je trouve que la distro parfaite existe. Chacune a ses avantages/inconvénients.
J'avoue que c'est ce que j'hésite à faire.
Surtout vu les pb que je rencontre sous suse pour l'instant.
Je ne sais pas trop quel est l'impact d'avoir des dépôts "expérimental" pour avoir pourtant des logiciels courants comme seafile ou x2go.

Re : Pas mal de logiciels manquants dans les dépôts leap

Répondre #8
Darktable en version 3.2.1 et même 3.3.0 existe dans les dépôts : https://software.opensuse.org/package/darktable
Il ne faut pas hésiter à aller piocher dans les dépôts communautaires.
Oui merci, j'avais vu pour la 3.2.1 mais pas pour la 3.3.0. Sinon je veux bien suivre ta recommendation mais j'hésite encore avec les dépôts communautaires car je marche toujours sur des oeufs (faut que j'assimile bien comment gérer ces dépôts et comment ils s'inscrivent dans le système de mise à jour).

Hello ;=)
pour info sur darktable et ses évolutions https://linuxfr.org/news/darktable-3-2-l-effet-confinement
Les posts sur Linuxfr.org  :o  ça ne plaisante pas! Et le boulot chez Darktable, tout pareil! Rien que l'amélioration des performances et la correction de bugs peuvent intéresser un novice (plus facile d'apprendre si le logiciel répond mieux). Merci pour l'info.

Je ne sais pas trop quel est l'impact d'avoir des dépôts "expérimental" pour avoir pourtant des logiciels courants comme seafile ou x2go.
Si la question se pose en ces termes, effectivement, je comprends (petite intervention pour te rendre la main sur ce fil  ;) )

Re : Pas mal de logiciels manquants dans les dépôts leap

Répondre #9
Oui elle se pose.  :(
J'ai du mal à comprendre comment une distrib à la renommé d'openSuse peut ne pas inclure ces logiciels dans les dépôts.

Re : Pas mal de logiciels manquants dans les dépôts leap

Répondre #10
De mon côté, j'ai ces 3 dépôts installés (dès l'installation du système) :
  • packman
  • graphics
  • Application_Geo
Du coup, j'ai darktable-3.2.1 ;)
Et pour le reste, il y a https://software.opensuse.org/explore...

Re : Pas mal de logiciels manquants dans les dépôts leap

Répondre #11
J'ai le dépôt parcman + libdvcss bien évidemment.
Et oui pour chercher les paquets je passe par software explorer mais du coup ça n'empêche que les seuls dépôts dispos étaient les communautaires ou les expérimentaux, il n'y avait rien d'autre de dispo.

Re : Pas mal de logiciels manquants dans les dépôts leap

Répondre #12
Bon pour donner l'exemple, sous debian, seafile, x2go font directement parti des dépôts. :/
Je ne me rappelle pas à l'époque ou j'utilisais openSuse avoir remarqué qu'il manquait des logiciels si "courants" dans les dépôts principaux.

Re : Pas mal de logiciels manquants dans les dépôts leap

Répondre #13
Pour info, j'ai installé récemment Opensuse Tumbleweed et il y a eu une mise à jour dans laquelle Firefox passe en version 80.

Si j'ai bien compris Leap est une version plus conservatrice et Tumbleweed offre plus souvent des mises à jours vers des versions stables des programmes ou de l'environnement de bureau. Tout fonctionne quand même très bien sur Tumbleweed. Pour un ordinateur perso c'est ce que je préfère. C'est seulement si j'avais un ordinateur au bureau réservé à du travail pro ou en entreprise que je choisirais Leap.

Je viens de regarder pour Darktable (que je connaissais pas), il s'installe en version 3.2.1 sur le Tumbleweed 20200910. :)


Re : Pas mal de logiciels manquants dans les dépôts leap

Répondre #14
Tumbleweed utilise firefox "normal" pas les versions ESR ce qui est logique. :)
Mais tumbleweed n'est pas exploitable dans mon cas, je préfère des distrib freezées  mais surtout cinnamon ne passe pas en tumbleweed (très vite des soucis de dépendances)