Aller au contenu principal
Sujet: Le bluetooth qui ne fonctionne qu'après une hibernation (Lu 148 fois) sujet précédent - sujet suivant

Le bluetooth qui ne fonctionne qu'après une hibernation

Bonjour,

il se passe quelque chose d'étrange depuis quelques temps dans mon ordinateur qui tourne sous tumbleweed. J'ai un petit adaptateur USB bluetooth qui ne démarre pas au démarrage de l'ordinateur:

[    9.440366] Bluetooth: hci0: command 0x1001 tx timeout
[   17.472366] Bluetooth: hci0: CSR: Local version failed (-110)

Mais si je mets l'ordinateur en hibernation et que je le redémarre:

[  371.354741] Bluetooth: hci0: CSR: Unbranded CSR clone detected; adding workarounds...
[  371.469566] NET: Registered protocol family 38
[  371.493097] Bluetooth: RFCOMM TTY layer initialized
[  371.493102] Bluetooth: RFCOMM socket layer initialized
[  371.493106] Bluetooth: RFCOMM ver 1.11

Le bluetooth fonctionne !

Que faire pour avoir le bluetooth qui démarre en même temps que l'ordinateur sans faire ce tour de passe passe ?

PS:

lsusb
Bus 001 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

Re : Le bluetooth qui ne fonctionne qu'après une hibernation

Répondre #1
Bonjour,
Il faut essayer les commandes suivantes :
sudo systemctl start bluetooth.service
sudo systemctl enable bluetooth.service

 

Re : Le bluetooth qui ne fonctionne qu'après une hibernation

Répondre #2
Tu pourrais essayer ces commandes-ci :

/usr/sbin/rfkill unblock bluetooth
sleep 1s
/usr/bin/hciconfig hci0 reset